summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-01-17 17:14:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:13:16 +0100
commitcba386c1295b7054df22dfb4662b1b92f668e2c0 (patch)
tree76078a073f62240b582c39cc20f8c9625edb6380 /configure.ac
parent341afe2a36125b11c1bc08bdc8f63421edaba008 (diff)
downloadguix-cba386c1295b7054df22dfb4662b1b92f668e2c0.tar.gz
build: Expand ‘scripts/guix’ at Make time.
This moves the complexity of Autotools variable expansion outside of the
application code.

* scripts/guix.in (config-lookup): Delete.
(maybe-augment-load-paths!, run-guix-main): Use fully expanded variables
instead of calling ‘config-lookup’.
* configure.ac: Don't use AC_CONFIG_FILES for ‘scripts/guix’.
Use AC_PROG_SED.
* Makefile.am (scripts/guix): New rule.
(do_subst): New variable.
(CLEANFILES, EXTRA_DIST): Adapt.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1e39122483..f69f796484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,8 @@ dnl Make sure we don't suffer from the bug in 'equal?' wrt. syntax objects
 dnl found in 2.2.1.  See <https://bugs.gnu.org/29903>.
 GUIX_ASSERT_SYNTAX_OBJECT_EQUAL
 
+AC_PROG_SED
+
 dnl Decompressors, for use by the substituter and other modules.
 AC_PATH_PROG([GZIP], [gzip])
 AC_PATH_PROG([BZIP2], [bzip2])
@@ -272,7 +274,6 @@ AC_CONFIG_FILES([Makefile
                  po/packages/Makefile.in
 		 guix/config.scm])
 
-AC_CONFIG_FILES([scripts/guix], [chmod +x scripts/guix])
 AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
 AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
   [chmod +x pre-inst-env])