summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-18 22:53:25 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-18 23:19:51 +0200
commite8cb9c01c684bed2f47767f0b322f3d40d89781a (patch)
tree45b21cca80a01b1515b1594f2db7d0c2263856c0 /configure.ac
parent45779fa676419de8838cb26b6c7a24678a2be1cd (diff)
downloadguix-e8cb9c01c684bed2f47767f0b322f3d40d89781a.tar.gz
build: Remove checks for 'nix-instantiate'.
* guix/import/snix.scm (open-nixpkgs): Use "nix-instantiate"
unconditionally.
* configure.ac: Remove check for 'nix-instantiate'.
* guix/config.scm.in (%nix-instantiate): Remove.
* guix/self.scm (%dependency-variables): Remove '%nix-instantiate'.
(make-config.scm): Remove it from the generated "config.scm".
* build-aux/build-self.scm (%dependency-variables, make-config.scm):
Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b866e91b2c..b34f15a77b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,18 +160,11 @@ AC_ARG_WITH([nix-prefix],
    esac],
   [])
 
-AC_PATH_PROG([NIX_INSTANTIATE], [nix-instantiate])
 AC_PATH_PROG([NIX_HASH], [nix-hash])
-if test "x$guix_build_daemon$NIX_INSTANTIATE$NIX_HASH" = "xno"; then
+if test "x$guix_build_daemon$NIX_HASH" = "xno"; then
    AC_MSG_ERROR([Nix programs not found; please install Nix or use `--with-nix-prefix'.])
 fi
 
-if test "x$NIX_INSTANTIATE" = "x"; then
-   # This program is an optional dependency, so we just want it to be
-   # taken from $PATH if it's not available right now.
-   NIX_INSTANTIATE="nix-instantiate"
-fi
-
 AC_ARG_WITH([nixpkgs],
   [AS_HELP_STRING([--with-nixpkgs=DIR],
     [search for Nixpkgs in DIR (for testing purposes only)])],