summary refs log tree commit diff
path: root/distro/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-12 22:25:16 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-12 22:25:16 +0100
commit39224d94e3f3ccc42aae924e9e0ce651d78e4c4b (patch)
tree3d479bc15d394f7c4f9af480cc5c633cbdf989be /distro/packages
parentfe8ccfcc7212a5610e547dbf29f3a04cde3e816a (diff)
downloadguix-39224d94e3f3ccc42aae924e9e0ce651d78e4c4b.tar.gz
distro: Add MySQL.
* distro/packages/mysql.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro/packages')
-rw-r--r--distro/packages/mysql.scm87
1 files changed, 87 insertions, 0 deletions
diff --git a/distro/packages/mysql.scm b/distro/packages/mysql.scm
new file mode 100644
index 0000000000..d98271a78b
--- /dev/null
+++ b/distro/packages/mysql.scm
@@ -0,0 +1,87 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages mysql)
+  #:use-module (distro)
+  #:use-module (distro packages perl)
+  #:use-module (distro packages linux)
+  #:use-module (distro packages openssl)
+  #:use-module (distro packages compression)
+  #:use-module (distro packages ncurses)
+  #:use-module ((guix licenses) #:select (gpl2))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public mysql
+  (package
+    (name "mysql")
+    (version "5.1.54")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://downloads.mysql.com/archives/mysql-5.1/mysql-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "07xbnwk7h1xya8s6dw34nrv7ampzag8l0l1szd2pc9zyqkzhydw4"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("procps" ,procps)
+       ("openssl" ,openssl)
+       ("perl" ,perl)
+       ("zlib" ,zlib)
+       ("ncurses" ,ncurses)))
+    (arguments
+     '(#:modules ((guix build gnu-build-system)
+                  (guix build utils)
+                  (ice-9 ftw))                    ; for "rm -rf"
+       #:phases (alist-cons-after
+                 'install 'clean-up
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   ;; Remove the 112 MiB of tests that get installed.
+                   (let ((out (assoc-ref outputs "out")))
+                     (define (rm-rf dir)
+                       (file-system-fold (const #t) ; enter?
+                                         (lambda (file stat result) ; leaf
+                                           (delete-file file))
+                                         (const #t)               ; down
+                                         (lambda (dir stat result) ; up
+                                           (rmdir dir))
+                                         (const #t)
+                                         (lambda (file stat errno result)
+                                           (format (current-error-port)
+                                                   "error: ~a: ~a~%"
+                                                   file (strerror errno)))
+                                         #t
+                                         (string-append out "/" dir)))
+                     (rm-rf "mysql-test")
+                     (rm-rf "sql-bench")
+
+                     ;; Compress the 14 MiB Info file.
+                     (zero?
+                      (system* "gzip" "--best"
+                               (string-append out "/share/info/mysql.info")))))
+                 %standard-phases)))
+    (home-page "http://www.mysql.com/")
+    (synopsis "A fast, easy to use, and popular database")
+    (description
+     "MySQL is a fast, reliable, and easy to use relational database
+management system that supports the standardized Structured Query
+Language.")
+    (license gpl2)))