summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-08-22 17:24:38 +0200
committerLudovic Courtès <ludo@gnu.org>2012-08-22 17:25:43 +0200
commit800cdeef31ccc92c9f54b62ec5276985d7b157b1 (patch)
tree81381bff713789d149aad1ebc354b42849ecebad /distro
parentaf5521ca019a81d1efc4428cec242bb4f9d77a05 (diff)
downloadguix-800cdeef31ccc92c9f54b62ec5276985d7b157b1.tar.gz
distro: Move patches to their own directory.
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES).
  (patchdir): New variable.
  (dist_patch_DATA): New variable.  Patch files formerly
  in $(nobase_dist_guilemodule_DATA).
  (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and
  `DISTRO_INSTALLED_PATCH_DIRECTORY'.
  (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'.

* distro.scm (%patch-directory): New variable.
  (search-patch): New procedure.
* distro/base.scm: Use `search-patch' instead of `(search-path
  %load-path ...)'.

* distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch,
  distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch,
  distro/make-impure-dirs.patch: Move to `distro/patches'.
Diffstat (limited to 'distro')
-rw-r--r--distro/base.scm17
-rw-r--r--distro/patches/findutils-absolute-paths.patch (renamed from distro/findutils-absolute-paths.patch)0
-rw-r--r--distro/patches/guile-1.8-cpp-4.5.patch (renamed from distro/guile-1.8-cpp-4.5.patch)0
-rw-r--r--distro/patches/m4-readlink-EINVAL.patch (renamed from distro/m4-readlink-EINVAL.patch)0
-rw-r--r--distro/patches/m4-s_isdir.patch (renamed from distro/m4-s_isdir.patch)0
-rw-r--r--distro/patches/make-impure-dirs.patch (renamed from distro/make-impure-dirs.patch)0
-rw-r--r--distro/patches/readline-link-ncurses.patch (renamed from distro/readline-link-ncurses.patch)0
7 files changed, 7 insertions, 10 deletions
diff --git a/distro/base.scm b/distro/base.scm
index 16f5b40e30..179910a129 100644
--- a/distro/base.scm
+++ b/distro/base.scm
@@ -17,6 +17,7 @@
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (distro base)
+  #:use-module (distro)
   #:use-module (guix packages)
   #:use-module (guix http)
   #:use-module (guix build-system gnu)
@@ -191,7 +192,7 @@ files (as archives).")
    (build-system gnu-build-system)
    (native-inputs
     `(("patch/absolute-paths"
-       ,(search-path %load-path "distro/findutils-absolute-paths.patch"))))
+       ,(search-patch "findutils-absolute-paths.patch"))))
    (arguments
     (case-lambda
       ((system)
@@ -245,10 +246,9 @@ The tools supplied with this package are:
                  `(#:patches (list (assoc-ref %build-inputs "patch/s_isdir")
                                    (assoc-ref %build-inputs
                                               "patch/readlink-EINVAL"))))))
-   (inputs `(("patch/s_isdir"
-              ,(search-path %load-path "distro/m4-s_isdir.patch"))
+   (inputs `(("patch/s_isdir" ,(search-patch "m4-s_isdir.patch"))
              ("patch/readlink-EINVAL"
-              ,(search-path %load-path "distro/m4-readlink-EINVAL.patch"))))
+              ,(search-patch "m4-readlink-EINVAL.patch"))))
    (description "GNU M4, a macro processor")
    (long-description
     "GNU M4 is an implementation of the traditional Unix macro processor.  It
@@ -280,8 +280,7 @@ macro processor in its own right.")
               "0ri98385hsd7li6rh4l5afcq92v8l2lgiaz85wgcfh4w2wzsghg2"))))
    (build-system gnu-build-system)
    (native-inputs
-    `(("patch/impure-dirs"
-       ,(search-path %load-path "distro/make-impure-dirs.patch"))))
+    `(("patch/impure-dirs" ,(search-patch "make-impure-dirs.patch"))))
    (arguments `(#:patches (list (assoc-ref %build-inputs
                                            "patch/impure-dirs"))))
    (description "GNU Make, a program controlling the generation of non-source
@@ -481,8 +480,7 @@ UNIX.  It has even been ported to OS/2 Warp!")
    (build-system gnu-build-system)
    (propagated-inputs `(("ncurses" ,ncurses)))
    (inputs `(("patch/link-ncurses"
-              ,(search-path %load-path
-                            "distro/readline-link-ncurses.patch"))))
+              ,(search-patch "readline-link-ncurses.patch"))))
    (arguments `(#:patches (list (assoc-ref %build-inputs
                                            "patch/link-ncurses"))
                 #:patch-flags '("-p0")))
@@ -664,8 +662,7 @@ records, each record containing an arbitrary number of named fields.")
                                                    match
                                                    (assoc-ref outputs "out")))))
                            %standard-phases)))
-   (inputs `(("patch/snarf"
-              ,(search-path %load-path "distro/guile-1.8-cpp-4.5.patch"))
+   (inputs `(("patch/snarf" ,(search-patch "guile-1.8-cpp-4.5.patch"))
              ("gawk" ,gawk)
              ("readline" ,readline)))
 
diff --git a/distro/findutils-absolute-paths.patch b/distro/patches/findutils-absolute-paths.patch
index 96341e281f..96341e281f 100644
--- a/distro/findutils-absolute-paths.patch
+++ b/distro/patches/findutils-absolute-paths.patch
diff --git a/distro/guile-1.8-cpp-4.5.patch b/distro/patches/guile-1.8-cpp-4.5.patch
index 638d071baf..638d071baf 100644
--- a/distro/guile-1.8-cpp-4.5.patch
+++ b/distro/patches/guile-1.8-cpp-4.5.patch
diff --git a/distro/m4-readlink-EINVAL.patch b/distro/patches/m4-readlink-EINVAL.patch
index dd371584a7..dd371584a7 100644
--- a/distro/m4-readlink-EINVAL.patch
+++ b/distro/patches/m4-readlink-EINVAL.patch
diff --git a/distro/m4-s_isdir.patch b/distro/patches/m4-s_isdir.patch
index a009a4ba44..a009a4ba44 100644
--- a/distro/m4-s_isdir.patch
+++ b/distro/patches/m4-s_isdir.patch
diff --git a/distro/make-impure-dirs.patch b/distro/patches/make-impure-dirs.patch
index 83a5fbe3a5..83a5fbe3a5 100644
--- a/distro/make-impure-dirs.patch
+++ b/distro/patches/make-impure-dirs.patch
diff --git a/distro/readline-link-ncurses.patch b/distro/patches/readline-link-ncurses.patch
index 0fd0598f46..0fd0598f46 100644
--- a/distro/readline-link-ncurses.patch
+++ b/distro/patches/readline-link-ncurses.patch