summary refs log tree commit diff
path: root/doc/contributing.texi
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-02-15 10:29:09 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-15 10:29:09 +0100
commit8d472e9314052403ad548f92ca6c10f9c961a087 (patch)
treee1600e4f62328cdde3d1f42c193d8419b6a67b3d /doc/contributing.texi
parentcfa6fdc54c58280e49330438aecfb5046ee9e63a (diff)
downloadguix-8d472e9314052403ad548f92ca6c10f9c961a087.tar.gz
doc: Move build commands to @example for clarity.
* doc/contributing.texi (Building from Git): Tweak so that all the
commands appear in @example boxes.  Show --localstatedir=/var instead of
--localstatedir=@var{directory}.
Diffstat (limited to 'doc/contributing.texi')
-rw-r--r--doc/contributing.texi45
1 files changed, 32 insertions, 13 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index c3d41e231f..207efc4ee6 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -98,8 +98,14 @@ shell}:
 guix shell -D guix help2man git strace --pure
 @end example
 
-Run @command{./bootstrap} to generate the build system infrastructure
-using Autoconf and Automake.  If you get an error like this one:
+From there you can generate the build system infrastructure
+using Autoconf and Automake:
+
+@example
+./bootstrap
+@end example
+
+If you get an error like this one:
 
 @example
 configure.ac:46: error: possibly undefined macro: PKG_CHECK_MODULES
@@ -120,17 +126,30 @@ export ACLOCAL_PATH=/usr/share/aclocal
 @xref{Macro Search Path,,, automake, The GNU Automake Manual}, for
 more information.
 
-Then, run @command{./configure --localstatedir=@var{directory}}, where
-@var{directory} is the @code{localstatedir} value used by your current
-installation (@pxref{The Store}, for information about this), usually
-@file{/var}.  Note that you will probably not run @command{make install}
-at the end (you don't have to) but it's still important to pass the
-right @code{localstatedir}.
-
-Finally, you have to invoke @code{make && make check} to build Guix and
-run the tests (@pxref{Running the Test Suite}).  If anything fails, take
-a look at installation instructions (@pxref{Installation}) or send a
-message to the @email{guix-devel@@gnu.org, mailing list}.
+Then, run:
+
+@example
+./configure --localstatedir=/var
+@end example
+
+@noindent
+... where @file{/var} is the normal @code{localstatedir} value
+(@pxref{The Store}, for information about this).  Note that you will
+probably not run @command{make install} at the end (you don't have to)
+but it's still important to pass the right @code{localstatedir}.
+
+Finally, you can build Guix and, if you feel so inclined, run the tests
+(@pxref{Running the Test Suite}):
+
+@example
+make
+make check
+@end example
+
+@noindent
+If anything fails, take a look at installation instructions
+(@pxref{Installation}) or send a message to the
+@email{guix-devel@@gnu.org, mailing list}.
 
 From there on, you can authenticate all the commits included in your
 checkout by running: