summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-10 09:40:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:02 +0200
commit36d7acf003f14af2203f4a35cdf2a9801cb1c672 (patch)
treec08733715012ad279fcad135b338303355d5b3f7 /doc
parentf1b21bcfb1c024a2830d3e2817970bd9056a7756 (diff)
downloadguix-36d7acf003f14af2203f4a35cdf2a9801cb1c672.tar.gz
gnu: Deprecate texlive-base in favor of texlive-scheme-basic.
* gnu/packages/tex.scm (texlive-base): Deprecate variable.
(texlive-updmap.cfg): Use default packages from now deprecated TEXLIVE-BASE.
Also remove already implemented TODO.
* doc/build.scm (pdf-manual):
* gnu/packages/statistics.scm: Replace TEXLIVE-BASE with call to
TEXLIVE-UPDMAP.CFG.
* guix/profiles.scm (texlive-font-maps): Trigger TeX Live hook whenever
a texlive package is included in the manifest.
Diffstat (limited to 'doc')
-rw-r--r--doc/build.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/doc/build.scm b/doc/build.scm
index 9c0cc99404..577f900e20 100644
--- a/doc/build.scm
+++ b/doc/build.scm
@@ -912,11 +912,10 @@ makeinfo OPTIONS."
                      sed
                      tar
                      texinfo
-                     texlive-base
-                     texlive-bin        ;for GUIX_TEXMF
-                     texlive-epsf
-                     texlive-ec
-                     texlive-texinfo)))))
+                     (texlive-updmap.cfg
+                      (list texlive-ec
+                            texlive-epsf
+                            texlive-texinfo)))))))
 
   (define build
     (with-imported-modules '((guix build utils))