summary refs log tree commit diff
path: root/doc
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-19 14:03:47 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 18:59:17 +0200
commitbbfb41ed9dff845e12ebd597026729f637903ac4 (patch)
treed4ddc615ca33ca685a8ac300a6d9fa430d827bea /doc
parentc22c29b0c4821ebe2c66a6c76562a41d33ff8392 (diff)
downloadguix-bbfb41ed9dff845e12ebd597026729f637903ac4.tar.gz
gnu: gnumach: Support "noide" argument.
* gnu/packages/patches/gnumach-support-noide.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/hurd.scm (gnumach-headers): Use it.
* doc/guix.texi (Bootloader Configuration): Document it.

Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi24
1 files changed, 23 insertions, 1 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 0cdc528c1c..8e4508b237 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -40078,7 +40078,29 @@ For example:
 @item @code{multiboot-arguments} (default: @code{'()})
 The list of extra command-line arguments for the multiboot-kernel.
 
-@item @code{multiboot-modules} (default: @code{'()})
+For example, when running in QEMU it can be useful to use a text-based
+console (use options @option{--nographic} @option{--serial mon:stdio}):
+
+@lisp
+'("console=com0")
+@end lisp
+
+To use the new and still experimental
+@uref{https://darnassus.sceen.net/~hurd-web/rump_kernel/, rumpdisk
+user-level disk driver} instead of GNU@tie{}Mach's in-kernel IDE driver,
+set @code{kernel-arguments} to:
+
+@lisp
+'("noide")
+@end lisp
+
+Of course, these options can be combined:
+
+@lisp
+'("console=com0" "noide")
+@end lisp
+
++@item @code{multiboot-modules} (default: @code{'()})
 The list of commands for loading Multiboot modules.  For example:
 
 @lisp