summary refs log tree commit diff
path: root/etc/guix-install.sh
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-02-20 17:29:58 -0800
committerChris Marusich <cmmarusich@gmail.com>2021-03-23 23:19:57 -0700
commita16eb6c5f97f136b678540ba61f12b2c08e43e13 (patch)
tree8eefe4fd67d683f8d3fff336441348ef0c5c4283 /etc/guix-install.sh
parentb50f42680352213beb64c248c1af2f9dcc1612fc (diff)
downloadguix-a16eb6c5f97f136b678540ba61f12b2c08e43e13.tar.gz
Add powerpc64le-linux as a supported Guix architecture.
This makes powerpc64le-linux a supported architecture for Guix, but not for
Guix System.

* Makefile.am (SUPPORTED_SYSTEMS): Add an entry for powerpc64le-linux.
* etc/guix-install.sh (chk_sys_arch): Same.
* guix/packages.scm (%supported-systems): Same.
* m4/guix.m4 (GUIX_ASSERT_SUPPORTED_SYSTEM): Same.
* tests/guix-build.sh (all_systems): Same.
Diffstat (limited to 'etc/guix-install.sh')
-rwxr-xr-xetc/guix-install.sh4
1 files changed, 4 insertions, 0 deletions
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 94c04aa646..c84e7b7577 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -8,6 +8,7 @@
 # Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
 # Copyright © 2020 Daniel Brooks <db48x@db48x.net>
 # Copyright © 2021 Jakub Kądziołka <kuba@kadziolka.net>
+# Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
 #
 # This file is part of GNU Guix.
 #
@@ -187,6 +188,9 @@ chk_sys_arch()
         armv7l)
             local arch=armhf
             ;;
+        ppc64le | powerpc64le)
+            local arch=powerpc64le
+            ;;
         *)
             _err "${ERR}Unsupported CPU type: ${arch}"
             exit 1