summary refs log tree commit diff
path: root/etc/release-manifest.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:48:19 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-03-10 08:49:48 +0100
commit76bea3f8bcd951ded88dfb7f8cad5bc3e5a1701f (patch)
tree22968402c681697e3fd23e5988d5e79f64a9b1a5 /etc/release-manifest.scm
parent4399b1cf572b1e23ac80a7b7d63daee34a77e104 (diff)
downloadguix-76bea3f8bcd951ded88dfb7f8cad5bc3e5a1701f.tar.gz
ci: Remove hydra support.
This removes hydra support to use Cuirass as the only continuous integration
system.

* build-aux/hydra/gnu-system.scm: Remove it.
* build-aux/hydra/guix-modular.scm: Ditto.
* build-aux/hydra/guix.scm: Ditto.
* build-aux/cuirass/hydra-to-cuirass.scm: Ditto.
* Makefile.am (EXTRA_DIST): Update it.
(hydra-jobs.scm): Remove it.
(cuirass-jobs.scm): Update it.
* build-aux/hydra/evaluate.scm: Move it to ...
* build-aux/cuirass/evaluate.scm: ... here.
* build-aux/cuirass/guix-modular.scm: Remove it.
* build-aux/cuirass/gnu-system.scm: Ditto.
* guix/packages.scm (%hydra-supported-systems): Rename it to ...
(%cuirass-supported-systems): ... this variable.
* build-aux/check-final-inputs-self-contained: Adapt it.
* etc/release-manifest.scm: Ditto.
* gnu/ci.scm (package->alist): Remove it.
(derivation->job): New procedure.
(package-job, package-cross-job, cross-jobs, image-jobs, system-test-jobs,
tarball-jobs): Use it.
(guix-jobs): New procedure.
(hydra-jobs): Rename it to ...
(cuirass-jobs): ... this procedure.
Diffstat (limited to 'etc/release-manifest.scm')
-rw-r--r--etc/release-manifest.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index da98d6e00b..a1f731a945 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -103,7 +103,7 @@ TARGET."
                       (if (string=? system "i586-gnu")
                           %base-packages/hurd
                           %base-packages)))
-               %hydra-supported-systems)))
+               %cuirass-supported-systems)))
 
 (define %system-manifest
   (manifest