summary refs log tree commit diff
path: root/etc/system-tests.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-27 00:12:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-27 00:12:15 +0100
commit18af6870370226b4d502d7372844e7f2aded5887 (patch)
tree749d93209bd0cb9710ccaae2207df670f37eaa36 /etc/system-tests.scm
parent0ab8ad46322bea331ed5f5592843ba35e7f38b37 (diff)
parent3089b70d766bd9ec70e1464867130b7b864fbe17 (diff)
downloadguix-18af6870370226b4d502d7372844e7f2aded5887.tar.gz
Merge branch 'master' into core-updates
 Conflicts:
	gnu/packages/icu4c.scm
	gnu/packages/man.scm
	gnu/packages/python-xyz.scm
	guix/scripts/environment.scm
	guix/scripts/pack.scm
	guix/scripts/package.scm
	guix/scripts/pull.scm
	guix/store.scm
Diffstat (limited to 'etc/system-tests.scm')
-rw-r--r--etc/system-tests.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/etc/system-tests.scm b/etc/system-tests.scm
index ab2827e70a..1085deed24 100644
--- a/etc/system-tests.scm
+++ b/etc/system-tests.scm
@@ -79,7 +79,11 @@ the 'TESTS' environment variable."
   ;; Intern SOURCE so that 'build-from-source' in (guix channels) sees
   ;; "fresh" file names and thus doesn't find itself loading .go files
   ;; from ~/.cache/guile when it loads 'build-aux/build-self.scm'.
-  (let* ((source (local-file source "guix-source"
+  (let* ((source (local-file source
+                             (if commit
+                                 (string-append "guix-"
+                                                (string-take commit 7))
+                                 "guix-source")
                              #:recursive? #t
                              #:select?
                              (or (git-predicate source)