summary refs log tree commit diff
path: root/gnu.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-13 19:14:31 -0400
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-10-16 18:34:17 -0500
commitfcd6fc84e493d05be1f7590ee77509c81ac315c2 (patch)
tree59554c5043b73e4a6a891b8dc7300736e84172eb /gnu.scm
parentb37e1e64281564c671bf3d0381bd9a6c03c6f62b (diff)
downloadguix-wip-deploy.tar.gz
scripts: Add deploy. wip-deploy
* gnu/machines.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
* guix/scripts/deploy.scm: New file.
* Makefile.am (MODULES): Add it.
* gnu.scm: Export (gnu machines) symbols.
* gnu/system/vm.scm (virtualized-operating-system): Export it.
Diffstat (limited to 'gnu.scm')
-rw-r--r--gnu.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu.scm b/gnu.scm
index 932e4cdd58..0edecb0311 100644
--- a/gnu.scm
+++ b/gnu.scm
@@ -43,6 +43,7 @@
         (gnu services base)
         (gnu packages)
         (gnu packages base)
+        (gnu machines)
         (guix gexp)))                             ; so gexps can be used
 
     (for-each (let ((i (module-public-interface (current-module))))