summary refs log tree commit diff
path: root/gnu/ci.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-09-12 08:31:36 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-12 09:27:57 +0200
commit7619a44c6874ae88d7615060549a2effe5fa9735 (patch)
treee46728721b0e468e871ccad9cca299a895e2c25e /gnu/ci.scm
parentbf35f660988098b2fc78f9aec7eede1a481e74fd (diff)
downloadguix-7619a44c6874ae88d7615060549a2effe5fa9735.tar.gz
gnu: Add compression module.
Move the compression record to a dedicated module so that it can be used
outside (guix scripts pack) module.

* guix/scripts/pack.scm (<compressor>, %compressors, lookup-compressor): Move
it to ...
* gnu/compression.scm: ... this new file.
* gnu/ci.scm: Adapt it.
* local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/ci.scm')
-rw-r--r--gnu/ci.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 2c51ea7387..19a48bdbf1 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -39,9 +39,10 @@
                 #:select (gpl3+ license? license-name))
   #:use-module ((guix utils) #:select (%current-system))
   #:use-module ((guix scripts pack)
-                #:select (lookup-compressor self-contained-tarball))
+                #:select (self-contained-tarball))
   #:use-module (gnu bootloader)
   #:use-module (gnu bootloader u-boot)
+  #:use-module (gnu compression)
   #:use-module (gnu image)
   #:use-module (gnu packages)
   #:use-module (gnu packages gcc)