summary refs log tree commit diff
path: root/gnu/installer/record.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-03-30 12:24:56 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-04-06 15:06:03 +0200
commit786c9c39bc0826737e99f0c750ea30033cdbc202 (patch)
treefbcd5bc021f312a2fed88013a1a526c6d0458c92 /gnu/installer/record.scm
parenta274bba2f939ae6637ec613bd0537ba415945835 (diff)
downloadguix-786c9c39bc0826737e99f0c750ea30033cdbc202.tar.gz
installer: Add a help page.
* gnu/installer/newt/help.scm: New file.
* gnu/local.mk (INSTALLER_MODULES): Add it.
* po/guix/POTFILES.in: Add it.
* gnu/installer/record.scm (<installer>): Add 'help-menu' and 'help-page'
 fields,
 (installer-help-menu, installer-help-page): new exported procedures.
 * gnu/installer/newt.scm (init): Set the help line,
 (help-menu, help-page): new procedures used ...
 (newt-installer): ... here.
 * gnu/installer/newt/keymap.scm (run-layout-page): Add a context argument to
 differenciate the help context from the main one,
 (run-keymap-page): add a context argument and pass it to run-layout-page.
 * gnu/installer.scm (compute-keymap-step): Add a context argument and pass it
 to 'installer-keymap-page',
 (installer-steps): set the help menu and pass the appropriate context to
 compute-keymap-step calls,
 (guile-newt): update to revision 2.
Diffstat (limited to 'gnu/installer/record.scm')
-rw-r--r--gnu/installer/record.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/installer/record.scm b/gnu/installer/record.scm
index edf73b6215..78acf50c63 100644
--- a/gnu/installer/record.scm
+++ b/gnu/installer/record.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2018, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -37,7 +37,9 @@
             installer-user-page
             installer-partition-page
             installer-services-page
-            installer-welcome-page))
+            installer-welcome-page
+            installer-help-menu
+            installer-help-page))
 
 
 ;;;
@@ -61,7 +63,7 @@
   (exit-error installer-exit-error)
   ;; procedure void -> void
   (final-page installer-final-page)
-  ;; procedure (layouts) -> (list layout variant)
+  ;; procedure (layouts context) -> (list layout variant)
   (keymap-page installer-keymap-page)
   ;; procedure: (#:key supported-locales iso639-languages iso3166-territories)
   ;; -> glibc-locale
@@ -81,4 +83,8 @@
   ;; procedure void -> void
   (services-page installer-services-page)
   ;; procedure (logo) -> void
-  (welcome-page installer-welcome-page))
+  (welcome-page installer-welcome-page)
+  ;; procedure (menu-proc) -> void
+  (help-menu installer-help-menu)
+  ;; procedure (keyboard-layout-selection) -> void
+  (help-page installer-help-page))