summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-27 15:38:45 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-27 15:46:24 +0200
commit17f168fcadcae78284d2b88accb4250a2e0d43fa (patch)
tree2cd4fec88bfe658af9a83c860a053f10999e3f68 /gnu/packages/admin.scm
parentad476912b6987507a0dc5b6d4b53bbf6a3708113 (diff)
downloadguix-17f168fcadcae78284d2b88accb4250a2e0d43fa.tar.gz
gnu: isc-dhcp: Do not refer to canonical coreutils.
Make sure not to retain a reference to the canonical coreutils and sed
packages.  The Guix System closure size would otherwise be increased by
including references to both canonical and non-canonical version of those
packages.

* gnu/packages/admin.scm (isc-dhcp)[inputs]: Add "coreutils" and "sed",
[arguments]: and use them, instead of their canonical counterpart.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 61a98cc1cc..5efe67b0cb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1042,10 +1042,10 @@ connection alive.")
                ;; if finds all the programs it needs.
                (let* ((out       (assoc-ref outputs "out"))
                       (libexec   (string-append out "/libexec"))
-                      (coreutils (assoc-ref inputs "coreutils"))
+                      (coreutils (assoc-ref inputs "coreutils*"))
                       (inetutils (assoc-ref inputs "inetutils"))
                       (net-tools (assoc-ref inputs "net-tools"))
-                      (sed       (assoc-ref inputs "sed")))
+                      (sed       (assoc-ref inputs "sed*")))
                  (substitute* "client/scripts/linux"
                    (("/sbin/ip")
                     (string-append (assoc-ref inputs "iproute")
@@ -1085,12 +1085,8 @@ connection alive.")
                      (base32
                       "1j9a4r83a77mp8k1y8z524c9rzdqgd8rzwczd6zwmw86a00xiimg"))))
 
-                ;; When cross-compiling, we need the cross Coreutils and sed.
-                ;; Otherwise just use those from %FINAL-INPUTS.
-                ,@(if (%current-target-system)
-                      `(("coreutils" ,coreutils)
-                        ("sed" ,sed))
-                      '())))
+                ("coreutils*" ,coreutils)
+                ("sed*" ,sed)))
 
       (home-page "https://www.isc.org/products/DHCP/")
       (synopsis "Dynamic Host Configuration Protocol (DHCP) tools")