summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-27 15:53:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-27 21:37:58 +0200
commit26a200f71c8407007c4eb8a85f685d21f551cb33 (patch)
tree87900861e588e577cd15a454ad2d44702e51d7d4 /gnu/packages/admin.scm
parent6b51f33fbfd39a6a546edaefa28b30f1d08a9442 (diff)
downloadguix-26a200f71c8407007c4eb8a85f685d21f551cb33.tar.gz
gnu: shadow: Merge in shadow-with-man-pages.
* gnu/packages/admin.scm (shadow)[arguments]: Add phase to install the
manpages. Make sure 'remove-groups comes after installing the manpages.
[properties]: Remove field.
(shadow-with-man-pages): Remove variable.
* gnu/system.scm (%base-packages-utils): Replace shadow-with-man-pages
with shadow.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm25
1 files changed, 7 insertions, 18 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index da832ac5c3..b2aadcc458 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -932,7 +932,13 @@ hostname.")
                (substitute* "lib/nscd.c"
                  (("/usr/sbin/nscd")
                   (string-append libc "/sbin/nscd"))))))
-         (add-after 'install 'remove-groups
+         (add-after 'install 'install-man-pages
+           (lambda _
+             ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
+             ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
+             ;; pages are available.  Thus, install them manually.
+             (invoke "make" "-C" "man" "install")))
+         (add-after 'install-man-pages 'remove-groups
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Remove `groups', which is already provided by Coreutils.
              (let* ((out (assoc-ref outputs "out"))
@@ -953,27 +959,10 @@ hostname.")
      "Shadow provides a number of authentication-related tools, including:
 login, passwd, su, groupadd, and useradd.")
 
-    (properties '((hidden? . #t)))                ;see below
-
     ;; The `vipw' program is GPLv2+.
     ;; libmisc/salt.c is public domain.
     (license license:bsd-3)))
 
-(define-public shadow-with-man-pages
-  ;; TODO: Merge with 'shadow' on the next core-updates cycle.
-  (package/inherit shadow
-    (properties '())                              ;not hidden
-    (arguments
-     (substitute-keyword-arguments (package-arguments shadow)
-       ((#:phases phases '%standard-phases)
-        `(modify-phases ,phases
-           (add-after 'install 'install-man-pages
-             (lambda _
-               ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
-               ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
-               ;; pages are available.  Thus, install them manually.
-               (invoke "make" "-C" "man" "install")))))))))
-
 (define-public mingetty
   (package
     (name "mingetty")