summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2023-11-28 14:08:34 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-03 23:55:08 +0100
commit27c24ce83f53e3453eedf5469560e3c4404ca81b (patch)
tree84946003edf02bb5fa6fbc1895adf2723842952e /gnu/packages/admin.scm
parent2447c1b6083290449f1bffd1e5953dd3d0820de9 (diff)
downloadguix-27c24ce83f53e3453eedf5469560e3c4404ca81b.tar.gz
gnu: igt-gpu-tools: Update to 1.28
* gnu/packages/admin.scm (igt-gpu-tools): Update to 1.28.
[source]: Remove patch.
[inputs]: Add python.
* gnu/packages/patches/igt-gpu-tools-Use-libproc2.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove it.

Change-Id: I5dccd7d5a5df0084fabf713949940775671aecd7
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 60bf87bf68..f4c5cd003e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3942,7 +3942,7 @@ buffers.")
 (define-public igt-gpu-tools
   (package
     (name "igt-gpu-tools")
-    (version "1.27.1")
+    (version "1.28")
     (source
      (origin
        (method git-fetch)
@@ -3951,9 +3951,7 @@ buffers.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0d6jsj77qddccv0vfmqmbw3k2prvxzvmgc8zdi83gdi3wpp5i7zd"))
-       (patches
-        (search-patches "igt-gpu-tools-Use-libproc2.patch"))))
+        (base32 "15mnsgzlpd4jkr2zy3jzx0b021g89fa61b8sdm8rjp27gxqkl8mm"))))
     (build-system meson-build-system)
     (arguments
      `(#:tests? #f              ; many of the tests try to load kernel modules
@@ -3971,7 +3969,8 @@ buffers.")
            libdrm
            libpciaccess
            libunwind
-           procps))
+           procps
+           python))
     (native-inputs
      (list bison flex pkg-config python-docutils))
     (home-page "https://gitlab.freedesktop.org/drm/igt-gpu-tools")