summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorSkyler <skyvine@protonmail.com>2023-09-07 02:01:51 +0000
committerLudovic Courtès <ludo@gnu.org>2023-09-14 16:50:40 +0200
commit9aeb9e7cc83d5d0e1aed7b34fb5a357645fd86a9 (patch)
tree8809babab04980a8dad651ecbf444976742254fe /gnu/packages/admin.scm
parent6c72db7314b6c355a2bd956da840e9a07a5b1929 (diff)
downloadguix-9aeb9e7cc83d5d0e1aed7b34fb5a357645fd86a9.tar.gz
gnu: rottlog: Add gawk as an input.
This avoids an issue where rottlog will delete the entire /tmp directory
if gawk is not installed.  See <https://issues.guix.gnu.org/65793>.

* gnu/packages/admin.scm (rottlog): Add gawk input, also update the
patch-paths build phase for awk invocations.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 98ed3d4e61..1b2324bfc7 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1978,7 +1978,11 @@ at once based on a Perl regular expression.")
             (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "rc/rc"
                 (("/usr/sbin/sendmail")
-                 (search-input-file inputs "/bin/mail")))))
+                 (search-input-file inputs "/bin/mail")))
+              (with-fluids ((%default-port-encoding "ISO-8859-1"))
+                (substitute* "src/rottlog"
+                  (("awk")
+                   (search-input-file inputs "/bin/awk"))))))
           (add-after 'build 'set-packdir
             (lambda _
               ;; Set a default location for archived logs.
@@ -1997,7 +2001,7 @@ at once based on a Perl regular expression.")
             (lambda _
               (invoke "make" "install-info"))))))
     (native-inputs (list autoconf automake texinfo util-linux)) ; for 'cal'
-    (inputs (list coreutils mailutils))
+    (inputs (list coreutils gawk mailutils))
     (home-page "https://www.gnu.org/software/rottlog/")
     (synopsis "Log rotation and management")
     (description