summary refs log tree commit diff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-16 02:58:43 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-16 19:44:42 +0200
commitfa67073f13a889589b4b0207e83891fe9226f2dc (patch)
treee71dc853a73120db9d595a9a23614f03198b3c1c /gnu/packages/admin.scm
parent4fce1ff1299e78770828f4e2fb35e61063b0b9dc (diff)
downloadguix-fa67073f13a889589b4b0207e83891fe9226f2dc.tar.gz
gnu: dstat: Fix Python 3 deprecation warning.
* gnu/packages/admin.scm (dstat)[arguments]:
Add ‘fix-python3-DeprecationWarning’ phase.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9392c59521..a897afdc0e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2142,6 +2142,11 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
                             "prefix=/"))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-python3-DeprecationWarning
+           (lambda _
+             (substitute* "dstat"
+               (("collections") "collections.abc"))
+             #t))
          (delete 'configure)            ; no configure script
          (add-after 'install 'wrap
            (lambda* (#:key outputs #:allow-other-keys)
@@ -2150,8 +2155,6 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
                  `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
                #t))))))
     (inputs
-     ;; Python 3 is supposedly supported but prints a DeprecationWarning.
-     ;; Upstream is dead.  See <https://github.com/dagwieers/dstat/releases>.
      `(("python" ,python-wrapper)
        ("python-six" ,python-six)))
     (synopsis "Versatile resource statistics tool")