summary refs log tree commit diff
path: root/gnu/packages/agda.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 10:11:29 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 10:11:29 +0200
commit4c204d01d57ac7da11a5772d5d4e3254d1c2408f (patch)
treec7e5cb013abc742734acd9613674df4ebddfdeef /gnu/packages/agda.scm
parent82bdb77082fa4e100761f70086b745dfb280c3ac (diff)
parent445a0359083388b5ee686e6e855f94a3aac5f79c (diff)
downloadguix-gnome-team.tar.gz
Merge branch 'master' into gnome-team gnome-team
Diffstat (limited to 'gnu/packages/agda.scm')
-rw-r--r--gnu/packages/agda.scm51
1 files changed, 24 insertions, 27 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 88626b823c..3748ab7059 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -262,34 +262,31 @@ try agda-prelude instead.")
   ;; Upstream's HEAD follows the latest Agda release, but they don't release
   ;; until a newer Agda release comes up, so their releases are always one
   ;; version late.
-  (let* ((revision "1")
-         (commit "814d54b08b360b8e80828065f54b80e3a98a0092"))
-    (package
-      (name "agda-cubical")
-      (version (git-version "0.4" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/agda/cubical.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0d25gb1qzpx539k62qjsjq4xmzp34qk7n3hmd9y6v8slhrrxw312"))))
-      (build-system agda-build-system)
-      (arguments
-       (list
-        #:gnu-and-haskell? #t
-        #:phases
-        #~(modify-phases %standard-phases
-            (replace 'build
-              (lambda _
-                (invoke "make"))))))
-      (synopsis "Standard library for Cubical Agda")
-      (description "A standard library for Cubical Agda, comparable to
+  (package
+    (name "agda-cubical")
+    (version "0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/agda/cubical.git")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0yfg7gr55n08ly1qgzpcp16s15k1abycppbcdi9lzg1hjryqxcg3"))))
+    (build-system agda-build-system)
+    (arguments
+     (list
+      #:gnu-and-haskell? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'build
+            (lambda _
+              (invoke "make"))))))
+    (synopsis "Standard library for Cubical Agda")
+    (description "A standard library for Cubical Agda, comparable to
 agda-stdlib but using cubical methods.")
-      (home-page "https://github.com/agda/cubical")
-      (license license:expat))))
+    (home-page "https://github.com/agda/cubical")
+    (license license:expat)))
 
 (define-public agda-1lab
   ;; Upstream doesn't do releases (yet).  Use a commit that builds with 2.6.3,