summary refs log tree commit diff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-16 19:20:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-18 06:36:39 +0300
commitecc5bc33a347b8f1792414abb43d1170f0b4dd1e (patch)
treee6bb3fdc40b3c679f52cf93bf48ced86198401f6 /gnu/packages/algebra.scm
parent8e71d6612d37629f8e77d7ab77c67d3623519543 (diff)
downloadguix-ecc5bc33a347b8f1792414abb43d1170f0b4dd1e.tar.gz
gnu: bc: Use 'modify-phases' syntax.
* gnu/packages/algebra.scm (bc)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 98bb2aeb71..1f34e86b23 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -479,22 +480,22 @@ binary.")
     (native-inputs `(("flex" ,flex)))
     (arguments
      '(#:phases
-       (alist-replace 'configure
-                      (lambda* (#:key outputs #:allow-other-keys)
-                        ;; This old `configure' script doesn't support
-                        ;; variables passed as arguments.
-                        (let ((out (assoc-ref outputs "out")))
-                          (setenv "CONFIG_SHELL" (which "bash"))
-                          (zero?
-                           (system*
-                            "./configure"
-                            (string-append "--prefix=" out)
-                            ;; By default, man and info pages are put in
-                            ;; PREFIX/{man,info}, but we want them in
-                            ;; PREFIX/share/{man,info}.
-                            (string-append "--mandir=" out "/share/man")
-                            (string-append "--infodir=" out "/share/info")))))
-                      %standard-phases)))
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; This old `configure' script doesn't support
+             ;; variables passed as arguments.
+             (let ((out (assoc-ref outputs "out")))
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (zero?
+                (system*
+                 "./configure"
+                 (string-append "--prefix=" out)
+                 ;; By default, man and info pages are put in
+                 ;; PREFIX/{man,info}, but we want them in
+                 ;; PREFIX/share/{man,info}.
+                 (string-append "--mandir=" out "/share/man")
+                 (string-append "--infodir=" out "/share/info")))))))))
     (home-page "https://www.gnu.org/software/bc/")
     (synopsis "Arbitrary precision numeric processing language")
     (description