summary refs log tree commit diff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-04-26 02:17:58 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 22:19:54 +0200
commitb98d4478187347d2c52ff5ff4c83fcb12346b505 (patch)
tree586fb38c99d0ffb341bb4ba32048d37a7df87107 /gnu/packages/android.scm
parentad23a3fbabb3cdc4ad19b524f517ad312768b92c (diff)
downloadguix-b98d4478187347d2c52ff5ff4c83fcb12346b505.tar.gz
gnu: Patch Android system core at the origin.
* gnu/packages/android.scm (android-platform-system-core): Add patches.
(libbase): Remove patches.
(adb): Remove patches.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 53b0183f92..ec32a5cfdf 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -95,7 +95,11 @@ use their packages mostly unmodified in our Android NDK build system.")
                               version "-checkout"))
     (sha256
      (base32
-      "0xc2n7jxrf1iw9cc278pijdfjix2fkiig5ws27f6rwp40zg5mrgg"))))
+      "0xc2n7jxrf1iw9cc278pijdfjix2fkiig5ws27f6rwp40zg5mrgg"))
+    (patches
+     (search-patches "libbase-use-own-logging.patch"
+                     "libbase-fix-includes.patch"
+                     "adb-add-libraries.patch"))))
 
 (define liblog
   (package
@@ -122,11 +126,7 @@ in Main, System, Radio and Events sub-logs.")
   (package
     (name "libbase")
     (version (android-platform-version))
-    (source (origin
-              (inherit (android-platform-system-core version))
-              (patches
-               (search-patches "libbase-use-own-logging.patch"
-                               "libbase-fix-includes.patch"))))
+    (source (android-platform-system-core version))
     (build-system android-ndk-build-system)
     (arguments
      `(#:tests? #f ; TODO.
@@ -197,12 +197,7 @@ various Android core host applications.")
   (package
     (name "adb")
     (version (android-platform-version))
-    (source (origin
-              (inherit (android-platform-system-core version))
-              (patches
-               (search-patches "libbase-use-own-logging.patch"
-                               "libbase-fix-includes.patch"
-                               "adb-add-libraries.patch"))))
+    (source (android-platform-system-core version))
     (build-system android-ndk-build-system)
     (arguments
      `(#:tests? #f ; TODO.