summary refs log tree commit diff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-12-02 11:32:17 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-02 11:32:17 +0100
commite1b88fde12305fca3c4a739a7e8f1449f42390f1 (patch)
tree1d9d014137455f438fcdf34d485fb665f9c96504 /gnu/packages/android.scm
parent8804215462bb8da1b6d905d32ad031e160136a43 (diff)
downloadguix-e1b88fde12305fca3c4a739a7e8f1449f42390f1.tar.gz
gnu: android-libselinux: Avoid top-level references to 'libsellinux'.
* gnu/packages/android.scm (android-libselinux)[synopsis]
[description, license]: Remove references to 'libsellinux'.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index e4dbade64c..30dd8925a4 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -500,9 +500,14 @@ that is safe to use for user space.  It also includes
        ;; pcre is inlined by our package.
        ("pcre" ,pcre)))
     (home-page "https://developer.android.com/")
-    (synopsis (package-synopsis libselinux))
-    (description (package-description libselinux))
-    (license (package-license libselinux))))
+    (synopsis "Android version of the SELinux libraries and utilities")
+    (description
+     "The libselinux library provides an API for SELinux applications to get
+and set process and file security contexts, and to obtain security policy
+decisions.  It is required for any applications that use the SELinux API, and
+used by all applications that are SELinux-aware.  This package also includes
+the core SELinux management utilities.")
+    (license license:public-domain)))
 
 (define-public android-ext4-utils
   (package