summary refs log tree commit diff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-08-21 01:32:22 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-08-21 01:41:58 +0200
commit2a29f4767fe2ed5eb89f4a324d987e81e4352f20 (patch)
tree08d10058e142168a9d97451c50425477e297dbc9 /gnu/packages/aspell.scm
parent1cc75fef122db08dd30a86a8074e7ac10fbc00c0 (diff)
downloadguix-2a29f4767fe2ed5eb89f4a324d987e81e4352f20.tar.gz
gnu: hunspell-dict-en: Install all affix files.
* gnu/packages/aspell.scm (aspell-word-list): Install affix files
corresponding to installed dictionary files.
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 22256f750b..daefbd01bd 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -404,8 +404,12 @@ dictionaries, including personal ones.")
                              (find-files "speller"
                                          ,(string-append language ".*\\.dic$"))))
 
-               (install-file ,(string-append "speller/" language ".aff")
-                             hunspell)
+               ;; Install affix files corresponding to installed dictionaries
+               (for-each (lambda (dic)
+                           (install-file (string-append
+                                           "speller/" (basename dic ".dic") ".aff")
+                                         hunspell))
+                         (find-files hunspell ".*\\.dic$"))
                (symlink hunspell (string-append myspell "/dicts"))
                (for-each (lambda (file)
                            (install-file file doc))