summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:26:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:34 +0100
commit06480b406bf47161b913107eeb9e09f71253a14e (patch)
tree27d0954757c1bbeb6cdd155b2ac4fbda0180b60d /gnu/packages/astronomy.scm
parent083c695d30902781f3e6257ebe1e4f9e2b84afdd (diff)
downloadguix-06480b406bf47161b913107eeb9e09f71253a14e.tar.gz
gnu: stuff: Sort alphabetically.
* gnu/packages/astronomy.scm (stuff): Sort alphabetically.

Change-Id: I7e609c91930c42b267e7e5ac51f5ff117446cfe3
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 126aed8728..3bfb5a1e0e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1633,33 +1633,6 @@ can be used to control telescopes over a serial port for tracking celestial
 objects.")
     (license license:gpl2+)))
 
-(define-public stuff
-  (package
-    (name "stuff")
-    (version "2.0.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/astromatic/stuff")
-             ;; XXX: No version tag available in GitHub.
-             ;; See: https://github.com/astromatic/stuff/issues/6
-             (commit "9008dc022ef53331092da248cf0a794abd6783bf")))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "004sry5lqqm7s9x4l3agysp3n63y3ga35x1rwwda4m6dc6zvla6b"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list autoconf automake libtool pkg-config))
-    (home-page "https://www.astromatic.net/software/stuff")
-    (synopsis "Astronomical catalogue simulation")
-    (description
-     "Stuff is a program that simulates \"perfect\" astronomical catalogues.
-It generates object lists in ASCII which can read by the SkyMaker program to
-produce realistic astronomical fields.  Stuff is part of the
-@uref{https://www.astromatic.net/projects/efigi, EFIGI} development project.")
-    (license license:gpl3+)))
-
 (define-public python-astropy
   (package
     (name "python-astropy")
@@ -5152,6 +5125,33 @@ using (multivariate) polynomials.")
 for reading and writing.")
     (license license:gpl2+)))
 
+(define-public stuff
+  (package
+    (name "stuff")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/astromatic/stuff")
+             ;; XXX: No version tag available in GitHub.
+             ;; See: https://github.com/astromatic/stuff/issues/6
+             (commit "9008dc022ef53331092da248cf0a794abd6783bf")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "004sry5lqqm7s9x4l3agysp3n63y3ga35x1rwwda4m6dc6zvla6b"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list autoconf automake libtool pkg-config))
+    (home-page "https://www.astromatic.net/software/stuff")
+    (synopsis "Astronomical catalogue simulation")
+    (description
+     "Stuff is a program that simulates \"perfect\" astronomical catalogues.
+It generates object lists in ASCII which can read by the SkyMaker program to
+produce realistic astronomical fields.  Stuff is part of the
+@uref{https://www.astromatic.net/projects/efigi, EFIGI} development project.")
+    (license license:gpl3+)))
+
 (define-public sunclock
   (let ((commit "f4106eb0a81f7594726d6b2859efd8fc64cc1225")
         (revision "1"))