summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 22:53:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-06 23:30:33 +0100
commita1ea196cc0ed31e2d9b92c18f125c4d9908c0e5e (patch)
treeeb61070ac1e98d7fe37f7aef3d7aeabd8364be2c /gnu/packages/astronomy.scm
parentd7543abe35d68d5eba1e48bc95473e2351f10447 (diff)
downloadguix-a1ea196cc0ed31e2d9b92c18f125c4d9908c0e5e.tar.gz
gnu: swarp: Sort alphabetically.
* gnu/packages/astronomy.scm (swarp): Sort alphabetically.

Change-Id: Ifb41e436ae7f59e597c391537b6ecd7b280d2930
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 908cd1cf5d..f342bb13ee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1558,31 +1558,6 @@ produce realistic astronomical fields.  Stuff is part of the
 @uref{https://www.astromatic.net/projects/efigi, EFIGI} development project.")
     (license license:gpl3+)))
 
-(define-public swarp
-  (package
-    (name "swarp")
-    (version "2.41.5")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/astromatic/swarp")
-             (commit (string-append version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "00463r5rd4xl74xs4h1n4gl2qk7v9p5nw9x05pbzgh8jm77q90qq"))))
-    (build-system gnu-build-system)
-    (native-inputs
-     (list automake autoconf libtool pkg-config))
-    (inputs
-     (list cfitsio))
-    (home-page "https://www.astromatic.net/software/swarp")
-    (synopsis "FITS image resampling and co-addition")
-    (description
-     "SWarp is a program that resamples and co-adds together FITS images using
-any arbitrary astrometric projection defined in the WCS standard.")
-    (license license:gpl3+)))
-
 (define-public celestia
   (package
     (name "celestia")
@@ -5296,6 +5271,31 @@ using (multivariate) polynomials.")
               ;; yt/frontends/artio/artio_headers/LICENSE: for C code.
               license:lgpl3))))
 
+(define-public swarp
+  (package
+    (name "swarp")
+    (version "2.41.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/astromatic/swarp")
+             (commit (string-append version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00463r5rd4xl74xs4h1n4gl2qk7v9p5nw9x05pbzgh8jm77q90qq"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list automake autoconf libtool pkg-config))
+    (inputs
+     (list cfitsio))
+    (home-page "https://www.astromatic.net/software/swarp")
+    (synopsis "FITS image resampling and co-addition")
+    (description
+     "SWarp is a program that resamples and co-adds together FITS images using
+any arbitrary astrometric projection defined in the WCS standard.")
+    (license license:gpl3+)))
+
 (define-public unsio
   ;; There is no versioned tag, use the latest commit.
   (let ((commit "25e52468298e1194c9726ef5dba9d5fbb46870f5")