summary refs log tree commit diff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-12-19 19:23:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-12 21:42:07 +0000
commitbfdcf6b36578ac0567f7e06651375d74688d22e5 (patch)
tree0b9d217b9a4a4201b74ed9f46fd2ab8932e6c37a /gnu/packages/astronomy.scm
parent1ef2e0bdf3d62137bb64e98a34f69e2c3454f3f1 (diff)
downloadguix-bfdcf6b36578ac0567f7e06651375d74688d22e5.tar.gz
gnu: python-regions: Use G-expressions.
* gnu/packages/astronomy.scm (python-regions): Use G-expressions.
[build-system]: Swap to pyproject-build-system.
[arguments]<#:phases>: Remove 'delete-doctest phase. Merge all
(add-before 'check ...) phases into 'prepare-test-environment.

Change-Id: I31dc6a195a6f6f818303d5c0e32799770cd448c8
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 76c60ca0a7..9b842621ee 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2283,21 +2283,20 @@ Virtual observatory (VO) using Python.")
        (uri (pypi-uri "regions" version))
        (sha256
         (base32 "09401pz7926zlci7cznd78hmv9947f6jxyy2afqdqc1xaccpzcq2"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:test-target "pytest"
-       #:phases
-       (modify-phases %standard-phases
-         ;; This doctest requires online data.
-         (add-after 'unpack 'delete-doctest
-           (lambda _ (delete-file "docs/masks.rst")))
-         ;; This file is opened in both install and check phases.
-         (add-before 'install 'writable-compiler
-           (lambda _ (make-file-writable "regions/_compiler.c")))
-         (add-before 'check 'writable-compiler
-           (lambda _ (make-file-writable "regions/_compiler.c")))
-         (add-before 'check 'writable-home
-           (lambda _  (setenv "HOME" (getcwd)))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; This file is opened in both install and check phases.
+          ;; XXX: Check if it is still required.
+          (add-before 'install 'writable-compiler
+            (lambda _ (make-file-writable "regions/_compiler.c")))
+          (add-before 'check 'prepare-test-environment
+            (lambda _
+              (setenv "HOME" "/tmp")
+              (make-file-writable "regions/_compiler.c")
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
     (propagated-inputs
      (list python-astropy
            python-h5py