summary refs log tree commit diff
path: root/gnu/packages/attr.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-25 16:19:06 +0200
commit2a552f1177fc79a66ba5ae53467556dfa3386b68 (patch)
treef3cd020fc101c848f630e5325e845ac688b101ae /gnu/packages/attr.scm
parenta7dc055bb5e07e716e929f8a906081fbe0422ad3 (diff)
downloadguix-2a552f1177fc79a66ba5ae53467556dfa3386b68.tar.gz
gnu: gettext, attr, acl: Disable `check' phase twiddling when cross building.
* gnu/packages/gettext.scm (gettext)[arguments]: Disable `check' phase
  manipulations when (%current-target-system) is true.
* gnu/packages/attr.scm (attr)[arguments]: Likewise.
* gnu/packages/acl.scm (acl)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/attr.scm')
-rw-r--r--gnu/packages/attr.scm47
1 files changed, 29 insertions, 18 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 254792f4ed..3fb15d235f 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -52,26 +52,37 @@
                            "install"
                            "install-lib"
                            "install-dev")))
-         (alist-replace
-          'check
-          (lambda _
-            ;; Use the right shell.
-            (substitute* "test/run"
-              (("/bin/sh")
-               (which "bash")))
 
-            (system* "make" "tests" "-C" "test")
+         ;; When building natively, adjust the test cases.
+         ,(if (%current-target-system)
+              '%standard-cross-phases
+              '(alist-replace 'check
+                              (lambda _
+                                ;; Use the right shell.
+                                (substitute* "test/run"
+                                  (("/bin/sh")
+                                   (which "bash")))
 
-            ;; XXX: Ignore the test result since this is dependent on the
-            ;; underlying file system.
-            #t)
-          %standard-phases)))))
-    (inputs `(("perl" ,perl)
-              ("gettext" ,guix:gettext)))
-    (home-page
-     "http://savannah.nongnu.org/projects/attr/")
-    (synopsis
-     "Library and tools for manipulating extended attributes")
+                                (system* "make" "tests" "-C" "test")
+
+                                ;; XXX: Ignore the test result since this is
+                                ;; dependent on the underlying file system.
+                                #t)
+                              %standard-phases))))))
+    (inputs `(;; Perl is needed to run tests; remove it from cross builds.
+              ,@(if (%current-target-system)
+                    '()
+                    `(("perl" ,perl)
+                      ("gettext" ,guix:gettext)))))
+    (native-inputs
+     ;; FIXME: Upon next core-updates, make gettext a native input
+     ;; unconditionally.
+     (if (%current-target-system)
+         `(("gettext" ,guix:gettext))
+         '()))
+
+    (home-page "http://savannah.nongnu.org/projects/attr/")
+    (synopsis "Library and tools for manipulating extended attributes")
     (description
      "Portable library and tools for manipulating extended attributes.")
     (license (list gpl2+ lgpl2.1+))))