summary refs log tree commit diff
path: root/gnu/packages/attr.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-22 16:32:30 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-22 16:32:30 +0200
commitee26820636c2521bb0a15bd960814bafa780635e (patch)
tree56212aefe8f59a6cd8d0850fab4ee5d70a0a56c8 /gnu/packages/attr.scm
parent8572bf5e0c921dfcd860a220e7646d1b3f4a90da (diff)
downloadguix-ee26820636c2521bb0a15bd960814bafa780635e.tar.gz
gnu: acl, attr: Make `gettext' a native input.
* gnu/packages/acl.scm (acl): Make `gettext' a native input, always.
* gnu/packages/attr.scm (attr): Likewise.
Diffstat (limited to 'gnu/packages/attr.scm')
-rw-r--r--gnu/packages/attr.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 2ce50296ac..3108a9072a 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -69,17 +69,13 @@
                                 ;; dependent on the underlying file system.
                                 #t)
                               %standard-phases))))))
-    (inputs `(;; Perl is needed to run tests; remove it from cross builds.
-              ,@(if (%current-target-system)
-                    '()
-                    `(("perl" ,perl)
-                      ("gettext" ,guix:gettext)))))
-    (native-inputs
-     ;; FIXME: Upon next core-updates, make gettext a native input
-     ;; unconditionally.
+    (inputs
+     ;; Perl is needed to run tests; remove it from cross builds.
      (if (%current-target-system)
-         `(("gettext" ,guix:gettext))
-         '()))
+         '()
+         `(("perl" ,perl))))
+    (native-inputs
+     `(("gettext" ,guix:gettext)))
 
     (home-page "http://savannah.nongnu.org/projects/attr/")
     (synopsis "Library and tools for manipulating extended attributes")