summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-13 00:11:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-13 00:16:27 +0200
commit82de3b60b5f55ac1dc1a5b582995f0ce5cf07cc3 (patch)
tree1b2931a140e949d0a437523d325a967bdc898bb9 /gnu/packages/audio.scm
parentd963e6d7219ee63d66329a89fa825731fba41fac (diff)
downloadguix-82de3b60b5f55ac1dc1a5b582995f0ce5cf07cc3.tar.gz
gnu: lvtk: Bump version number.
This is really version 2.x of the API.

* gnu/packages/audio.scm (lvtk): Rename this variable...
(lvtk-2): ...to this.
[version]: Bump major version to 2.
(lvtk): Alias to lvtk-1.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6421e1287d..9a770966e3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2861,14 +2861,14 @@ generate C headers from Turtle files.")
     (synopsis "LV2 port of the mda EPiano plugin")
     (description "An LV2 port of the mda EPiano VSTi.")))
 
-(define-public lvtk
+(define-public lvtk-2
   ;; Use the latest commit, as the latest release was made in 2014 and depends
   ;; on Python 2.
   (let ((commit "a73feabe772f9650aa071e6a4df660e549ab7c48")
         (revision "0"))
     (package
       (name "lvtk")
-      (version (git-version "1.2.0" revision commit))
+      (version (git-version "2" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -2931,6 +2931,8 @@ extensions into easy to use C++ classes.  It is the successor of
 lv2-c++-tools.")
       (license license:isc))))
 
+(define-public lvtk lvtk-1)
+
 (define-public openal
   (package
     (name "openal")