summary refs log tree commit diff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2017-09-06 12:51:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2017-09-06 12:51:59 +0200
commitf049e79dc34c112fca244946256920a5ce2e9db0 (patch)
tree8aba1bcbaae63b91f0da250c66cdc8eacc439d23 /gnu/packages/audio.scm
parent026ebc141ff9eb6147c9538f004119193d4cfe49 (diff)
downloadguix-f049e79dc34c112fca244946256920a5ce2e9db0.tar.gz
gnu: csound: Update to 6.09.1.
* gnu/packages/audio.scm (csound): Update to 6.09.1.  Change source URI.
* gnu/packages/patches/csound-header-ordering.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove reference to patch above.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e27c13bed4..1b7950cf00 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -568,23 +568,17 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
 (define-public csound
   (package
     (name "csound")
-    (version "6.05")
+    (version "6.09.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "mirror://sourceforge/csound/csound6/Csound"
-                    version "/Csound" version ".tar.gz"))
+                    "https://github.com/csound/csound/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))
-              (patches (search-patches "csound-header-ordering.patch"))))
+                "0f67vyy3r29hn26qkkcwnizrnzzy8p7gmg3say5q3wjhxns3b5yl"))))
     (build-system cmake-build-system)
-    (arguments
-     ;; Work around this error on x86_64 with libc 2.22+:
-     ;;    libmvec.so.1: error adding symbols: DSO missing from command line
-     (if (string-prefix? "x86_64" (or (%current-target-system) (%current-system)))
-         '(#:configure-flags '("-DCMAKE_EXE_LINKER_FLAGS=-lmvec"))
-         '()))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("boost" ,boost)