summary refs log tree commit diff
path: root/gnu/packages/augeas.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-09 11:01:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-09 11:01:53 +0300
commit8658b81b1acb2d84171914236f63f5b9038f76ea (patch)
tree1282e0e4867b1ae736017e5ac289ddf5b544c716 /gnu/packages/augeas.scm
parent8d18edde755f4bf5b4723fc9ce89e1cd831d2b7b (diff)
downloadguix-8658b81b1acb2d84171914236f63f5b9038f76ea.tar.gz
gnu: augeas: Update to 1.11.0.
* gnu/packages/augeas.scm (augeas): Update to 1.11.0.
[source]: Remove snippet.
Diffstat (limited to 'gnu/packages/augeas.scm')
-rw-r--r--gnu/packages/augeas.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/augeas.scm b/gnu/packages/augeas.scm
index 9495d4a0a4..fcba5bae7b 100644
--- a/gnu/packages/augeas.scm
+++ b/gnu/packages/augeas.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -32,24 +32,14 @@
 (define-public augeas
   (package
     (name "augeas")
-    (version "1.10.1")
+    (version "1.11.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.augeas.net/augeas-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0k9nssn7lk58cl5zv3c8kv2zx9cm2yks3sj7q4fd6qdjz9m2bnsj"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  ;; The gnulib test-lock test is prone to writer starvation
-                  ;; with our glibc@2.25, which prefers readers, so disable it.
-                  ;; The gnulib commit b20e8afb0b2 should fix this once
-                  ;; incorporated here.
-                  (substitute* "gnulib/tests/Makefile.in"
-                    (("test-lock\\$\\(EXEEXT\\) ") ""))
-                  #t))))
+                "1c507qj6dfn2dnsl27w94zs9r45xrgm07y8bqba9ry2s0psfhg1r"))))
     (build-system gnu-build-system)
     ;; Marked as "required" in augeas.pc
     (propagated-inputs