summary refs log tree commit diff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
commita22dc0c49aed0babe16ef92ae24847b343b7eb02 (patch)
tree2d1ce88952d68274437dc07fbffbea688bc0eea3 /gnu/packages/autotools.scm
parent668d48a6847bcdc69d2c6e6aa44090f566ecd05b (diff)
downloadguix-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar.gz
Synchronize package descriptions with the Womb.
* gnu/packages/algebra.scm,
  gnu/packages/aspell.scm,
  gnu/packages/autotools.scm,
  gnu/packages/base.scm,
  gnu/packages/bash.scm,
  gnu/packages/bison.scm,
  gnu/packages/cdrom.scm,
  gnu/packages/cflow.scm,
  gnu/packages/compression.scm,
  gnu/packages/cpio.scm,
  gnu/packages/cppi.scm,
  gnu/packages/ddrescue.scm,
  gnu/packages/dejagnu.scm,
  gnu/packages/ed.scm,
  gnu/packages/emacs.scm,
  gnu/packages/fdisk.scm,
  gnu/packages/freeipmi.scm,
  gnu/packages/gawk.scm,
  gnu/packages/gcal.scm,
  gnu/packages/gcc.scm,
  gnu/packages/gdb.scm,
  gnu/packages/gdbm.scm,
  gnu/packages/gettext.scm,
  gnu/packages/ghostscript.scm,
  gnu/packages/global.scm,
  gnu/packages/gnunet.scm,
  gnu/packages/gnupg.scm,
  gnu/packages/gnutls.scm,
  gnu/packages/gperf.scm,
  gnu/packages/gprolog.scm,
  gnu/packages/groff.scm,
  gnu/packages/grub.scm,
  gnu/packages/gsasl.scm,
  gnu/packages/guile.scm,
  gnu/packages/gv.scm,
  gnu/packages/help2man.scm,
  gnu/packages/idutils.scm,
  gnu/packages/indent.scm,
  gnu/packages/less.scm,
  gnu/packages/libidn.scm,
  gnu/packages/libsigsegv.scm,
  gnu/packages/libunistring.scm,
  gnu/packages/lightning.scm,
  gnu/packages/linux.scm,
  gnu/packages/lsh.scm,
  gnu/packages/m4.scm,
  gnu/packages/mail.scm,
  gnu/packages/maths.scm,
  gnu/packages/multiprecision.scm,
  gnu/packages/nano.scm,
  gnu/packages/ncurses.scm,
  gnu/packages/nettle.scm,
  gnu/packages/ocrad.scm,
  gnu/packages/oggvorbis.scm,
  gnu/packages/parted.scm,
  gnu/packages/plotutils.scm,
  gnu/packages/pth.scm,
  gnu/packages/readline.scm,
  gnu/packages/recutils.scm,
  gnu/packages/rush.scm,
  gnu/packages/scheme.scm,
  gnu/packages/screen.scm,
  gnu/packages/shishi.scm,
  gnu/packages/smalltalk.scm,
  gnu/packages/system.scm,
  gnu/packages/texinfo.scm,
  gnu/packages/time.scm,
  gnu/packages/unrtf.scm,
  gnu/packages/version-control.scm,
  gnu/packages/wdiff.scm,
  gnu/packages/wget.scm,
  gnu/packages/which.scm,
  gnu/packages/xnee.scm,
  gnu/packages/zile.scm: Change value of the 'description' field to that
  of the Womb.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 580e43eff3..ab0c7dcbdf 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -52,13 +52,11 @@
      "http://www.gnu.org/software/autoconf/")
     (synopsis "Create source code configuration scripts")
     (description
-     "GNU Autoconf is an extensible package of M4 macros that produce
-shell scripts to automatically configure software source code
-packages.  These scripts can adapt the packages to many kinds of
-UNIX-like systems without manual user intervention.  Autoconf
-creates a configuration script for a package from a template
-file that lists the operating system features that the package
-can use, in the form of M4 macro calls.")
+     "Autoconf offers the developer a robust set of M4 macros which expand
+into shell code to test the features of Unix-like systems and to adapt
+automatically their software package to these systems.  The resulting shell
+scripts are self-contained and portable, freeing the user from needing to
+know anything about Autoconf or M4.")
     (license gpl3+))) ; some files are under GPLv2+
 
 (define-public autoconf-wrapper
@@ -202,9 +200,10 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
     (home-page "http://www.gnu.org/software/automake/")
     (synopsis "Making GNU standards-compliant Makefiles")
     (description
-     "GNU Automake is a tool for automatically generating
-`Makefile.in' files compliant with the GNU Coding
-Standards.  Automake requires the use of Autoconf.")
+     "Automake the part of the GNU build system for producing standards-
+compliant Makefiles.  Build requirements are entered in an intuitive format
+and then Automake works with Autoconf to produce a robust Makefile,
+simplifying the entire process for the developer.")
     (license gpl2+)))                      ; some files are under GPLv3+
 
 (define-public libtool
@@ -258,11 +257,8 @@ Standards.  Automake requires the use of Autoconf.")
                ,(search-patch "libtool-skip-tests.patch"))))
     (synopsis "Generic shared library support tools")
     (description
-     "GNU libtool is a generic library support script.  Libtool hides the
-complexity of using shared libraries behind a consistent, portable interface.
-
-To use libtool, add the new generic library building commands to your
-Makefile, Makefile.in, or Makefile.am.  See the documentation for
-details.")
+     "Libtool is a script to help in the creation of shared libraries.  By
+presenting a consistent, portable interface, it hides the complexity of
+building usable shared libraries.")
     (license gpl3+)
     (home-page "http://www.gnu.org/software/libtool/")))