summary refs log tree commit diff
path: root/gnu/packages/aux-files/guix.vim
diff options
context:
space:
mode:
authorJonathan Scoresby <me@jonscoresby.com>2023-10-16 12:15:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-08 10:28:55 +0200
commitb17567d45c03b7125bfe0255f4ac45d5db81a268 (patch)
treeab1e674f51a4593468768a0b45b43184042cc95e /gnu/packages/aux-files/guix.vim
parente8739da12e3cf9bc0477c3df65875de6a64d74c5 (diff)
downloadguix-b17567d45c03b7125bfe0255f4ac45d5db81a268.tar.gz
gnu: vim: Add vim packages to 'package-path' instead of 'runtime-path'.
    This is neccesary because vim's built-in plugin manager looks for directories
    under 'package-path' instead of 'runtime-path.' Once we have told vim the
    package-path, it adds all the packages to the runtime-path automatically for us.

* gnu/packages/aux-files/guix.vim: Add paths to packagepath instead of
runtimepath.  Remove code to adjust runtimepath after adding paths.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/aux-files/guix.vim')
-rw-r--r--gnu/packages/aux-files/guix.vim11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
index 9397c53701..24a6b941a8 100644
--- a/gnu/packages/aux-files/guix.vim
+++ b/gnu/packages/aux-files/guix.vim
@@ -1,13 +1,8 @@
-" This appends all of the vim plugins to the end of Vim's runtimepath.
+" This appends all applicable vim paths to the end of packagepath.  Once we
+" have told vim the packagepath vim will add it to the runtimepath for us.
 for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $HOME ."/.guix-home/profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
     let vimplugins = directory . "/share/vim/vimfiles"
     if isdirectory(vimplugins)
-        let &rtp = join([&rtp,vimplugins], ',')
+        let &pp = join([&pp,vimplugins], ',')
     endif
 endfor
-" Unconditionally add */after directories last, as intended by upstream
-" TODO: Remove duplicate */after directories
-for directory in [$VIM . "/vimfiles", $HOME ."/.vim"]
-    let vimplugins = directory . "/after"
-    let &rtp = join([&rtp,vimplugins], ',')
-endfor