summary refs log tree commit diff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:40:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:58:58 +0100
commitedb8aa3a28d410ef6fcb9355b57f9be26f87caed (patch)
tree7e0b6045c6c8d5a6e1491627f04f0368bc46cb68 /gnu/packages/avahi.scm
parent6711ad08c723ffa21a0307c41aa8f966b7614cdd (diff)
downloadguix-edb8aa3a28d410ef6fcb9355b57f9be26f87caed.tar.gz
gnu: avahi: Incorporate grafted changes.
* gnu/packages/avahi.scm (avahi)[replacement]: Remove.
[source](patches): Add avahi-CVE-2018-1000845.patch.
[properties]: New field.
(avahi/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index e84fed6a71..f82a421e08 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -35,7 +35,6 @@
   (package
     (name "avahi")
     (version "0.7")
-    (replacement avahi/fixed)
     (home-page "http://avahi.org")
     (source (origin
              (method url-fetch)
@@ -44,7 +43,10 @@
              (sha256
               (base32
                "0128n7jlshw4bpx0vg8lwj8qwdisjxi7mvniwfafgnkzzrfrpaap"))
-             (patches (search-patches "avahi-localstatedir.patch"))))
+             (patches (search-patches "avahi-localstatedir.patch"
+                                      "avahi-CVE-2018-1000845.patch"))))
+    ;; Hide a duplicate of the CVE fixed above.
+    (properties `((lint-hidden-cve . ("CVE-2017-6519"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--with-distro=none"
@@ -75,17 +77,6 @@ network.  It is an implementation of the mDNS (for \"Multicast DNS\") and
 DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
     (license lgpl2.1+)))
 
-(define avahi/fixed
-  (package
-    (inherit avahi)
-    (source (origin
-              (inherit (package-source avahi))
-              (patches
-               (append (search-patches "avahi-CVE-2018-1000845.patch")
-                       (origin-patches (package-source avahi))))))
-    ;; Hide a duplicate of the CVE fixed above.
-    (properties `((lint-hidden-cve . ("CVE-2017-6519"))))))
-
 (define-public nss-mdns
   (package
     (name "nss-mdns")