summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 11:20:43 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:31 +0200
commit2ff1a14bdaf10262d86bcb8d8d319b71b3407a02 (patch)
treeb0a60eb34fd2c8a29f5f64aa5f7fda2996ab0712 /gnu/packages/backup.scm
parenta00a3eb1cf97c156756244e29d1276e062d2b791 (diff)
downloadguix-2ff1a14bdaf10262d86bcb8d8d319b71b3407a02.tar.gz
gnu: libarchive: Update to 3.6.1.
* gnu/packages/backup.scm (libarchive): Update to 3.6.1.
[arguments]: Enable one test.
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 5646d909e5..aedb7277c4 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -238,7 +238,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 (define-public libarchive
   (package
     (name "libarchive")
-    (version "3.5.1")
+    (version "3.6.1")
     (source
      (origin
        (method url-fetch)
@@ -249,7 +249,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
                                  version ".tar.xz")))
        (sha256
         (base32
-         "16r95rlmikll1k8vbhh06vq6x3srkc10hzxjjf3021mjs2ld65qf"))))
+         "1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas"))))
     (build-system gnu-build-system)
     (inputs
      (list bzip2
@@ -275,16 +275,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 		 ;; test_write_disk_lookup tests expect user 'root' to
 		 ;; exist, but the chroot's /etc/passwd doesn't have
 		 ;; it.  Turn off those tests.
-		 ;;
-		 ;; XXX: Adjust test that fails with zstd 1.4.1
-		 ;; because the default options compresses two bytes
-		 ;; better than this test expects.
-		 ;; https://github.com/libarchive/libarchive/issues/1226
                  (begin
-                   (substitute* "libarchive/test/test_write_filter_zstd.c"
-		     (("compression-level\", \"6\"")
-		      "compression-level\", \"7\""))
-
 		   ;; The tests allow one to disable tests matching a globbing pattern.
 		   (invoke "make"
 			   "libarchive_test"