summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 10:59:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:54 +0100
commit3e656b6354b7f374c1f8c874a33e4193690b27ff (patch)
tree522791b0941a03e263c5e28bd81db0db3e62bf57 /gnu/packages/backup.scm
parent0595f60fa749f44eea392059820dd0da33f2c1de (diff)
downloadguix-3e656b6354b7f374c1f8c874a33e4193690b27ff.tar.gz
gnu: restic: Use go-1.17.
* gnu/packages/backup.scm (restic): [arguments]: <#:go>: Pin to go-1.17.

Change-Id: I63267c2bdb3e983475cf75b285021c71ac578e1a
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 637a873fbf..19c261ea82 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -952,7 +952,11 @@ is like a time machine for your data.")
                (search-patches "restic-0.9.6-fix-tests-for-go1.15.patch"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/restic/restic"
+     `(;; XXX: Tests failed on a newer version of Golang, newer version of
+       ;; restic does not provide vendor folder any longer which means - a
+       ;; long way of packaging missing inputs.
+       #:go ,go-1.17
+       #:import-path "github.com/restic/restic"
       ;; We don't need to install the source code for end-user applications.
        #:install-source? #f
        #:phases