summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-04-24 09:54:05 +0800
committerMathieu Othacehe <othacehe@gnu.org>2022-04-26 09:24:08 +0200
commitd762e1c88c7a65417fed6f58a43bd312dc28ddcd (patch)
treec01e2e4d8cb03f7d7e7b97c9933cc00041a2df01 /gnu/packages/backup.scm
parent5c450082f797beee5dc0c446010425aa0f191056 (diff)
downloadguix-d762e1c88c7a65417fed6f58a43bd312dc28ddcd.tar.gz
gnu: Add grsync.
* gnu/packages/backup.scm (grsync): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 36bb2ae8e2..7bddd1c378 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Feng Shu <tumashu@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -71,6 +72,7 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
   #:use-module (gnu packages linux)
@@ -1340,3 +1342,27 @@ tool.  It supports the use of remote backup repositories.  It can perform
 scheduled backups, and has a graphical tool for browsing and extracting the Borg
 archives.")
     (license license:gpl3+)))
+
+(define-public grsync
+  (package
+    (name "grsync")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.opbyte.it/release/"
+                                  "grsync-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1z1m782b50x348kgynzf753apy8yszkl31y32y1jsc055skcdixp"))))
+    (build-system gnu-build-system)
+    (native-inputs (list intltool pkg-config))
+    (inputs (list gtk+))
+    (propagated-inputs (list rsync))
+    (home-page "http://www.opbyte.it/grsync/")
+    (synopsis "GTK frontend for rsync")
+    (description
+     "Grsync is a simple graphical interface using GTK for the @command{rsync}
+command line program.  It currently supports only a limited set of the most
+important rsync features, but can be used effectively for local directory
+synchronization.")
+    (license license:gpl2)))