summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-03 14:49:55 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-03 14:50:29 +0100
commit1575dcd134f4fae7255787293f4988bbd043de95 (patch)
treef28435580023f52e9cddc1067c4be6fad56de91d /gnu/packages/base.scm
parentdd1937d75dd0fb21402515ca56e06cca2ee095a7 (diff)
downloadguix-1575dcd134f4fae7255787293f4988bbd043de95.tar.gz
gnu: grep: Skip timing-sensitive test.
This avoids failures on loaded machines as seen
at <http://hydra.gnu.org/build/906900/log/raw>.

* gnu/packages/patches/grep-timing-sensitive-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/base.scm (grep): Use it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a55711e9ea..a7b74cfb93 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -80,7 +80,9 @@ command-line arguments, multiple languages, and so on.")
                                 version ".tar.xz"))
             (sha256
              (base32
-              "1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))))
+              "1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))
+            (patches
+             (list (search-patch "grep-timing-sensitive-test.patch")))))
    (build-system gnu-build-system)
    (native-inputs `(("perl" ,perl)))             ;some of the tests require it
    (synopsis "Print lines matching a pattern")