summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-27 10:25:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-27 10:25:45 +0200
commit51c8e2996c63311efc60e92743df21cd07044544 (patch)
treeb0f56254243aa604405dd9a1426c4d032c46d50c /gnu/packages/base.scm
parentb7a5a4821f4dd48aaa69a87eddfe7ee10c9486c6 (diff)
downloadguix-51c8e2996c63311efc60e92743df21cd07044544.tar.gz
gnu: sed: Use 'modify-phases' syntax.
* gnu/packages/base.scm (sed)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 52b035f385..8aa426959f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -131,16 +131,17 @@ including, for example, recursive directory searching.")
    (arguments
     (if (%current-target-system)
         '()
-        `(#:phases (alist-cons-before
-                    'patch-source-shebangs 'patch-test-suite
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      (let ((bash (assoc-ref inputs "bash")))
-                        (patch-makefile-SHELL "testsuite/Makefile.tests")
-                        (substitute* '("testsuite/bsd.sh"
-                                       "testsuite/bug-regex9.c")
-                          (("/bin/sh")
-                           (string-append bash "/bin/bash")))))
-                    %standard-phases))))
+        `(#:phases
+          (modify-phases %standard-phases
+            (add-before 'patch-source-shebangs 'patch-test-suite
+              (lambda* (#:key inputs #:allow-other-keys)
+                (let ((bash (assoc-ref inputs "bash")))
+                  (patch-makefile-SHELL "testsuite/Makefile.tests")
+                  (substitute* '("testsuite/bsd.sh"
+                                 "testsuite/bug-regex9.c")
+                    (("/bin/sh")
+                     (string-append bash "/bin/bash")))
+                  #t)))))))
    (description
     "Sed is a non-interactive, text stream editor.  It receives a text
 input from a file or from standard input and it then applies a series of text