summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-06 10:59:45 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:02 +0200
commit74e49ef9dcf430476c8ebe214bb67219e9bb7926 (patch)
treefa8997c8e110f0ace87a67ed55cef57b0f16df37 /gnu/packages/base.scm
parente72150039fa15d8f78fa5d2386f0289d7f94a8be (diff)
downloadguix-74e49ef9dcf430476c8ebe214bb67219e9bb7926.tar.gz
gnu: glibc: Remove unneeded workaround configure flags for Hurd.
* gnu/packages/base.scm (%glibc/hurd-configure-flags): Remove variable.
(glibc): Stop using %glibc/hurd-configure-flags.

Change-Id: I5cbdf8956a826d1eb25c449d4bc8a16d87dc8b80
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fbff716495..a205a20094 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -818,17 +818,6 @@ the store.")
     (home-page "https://www.gnu.org/software/guix//")
     (license gpl3+)))
 
-(define-public %glibc/hurd-configure-flags
-  ;; 'configure' in glibc 2.35 omits to pass '-ffreestanding' when detecting
-  ;; Mach headers.  This is fixed in glibc commits
-  ;; 8b8c768e3c701ed1993789bb46acb8a12c7a93df and
-  ;; 7685630b98ca2a3f5de86eadf130993e6cf998a0; as a workaround, bypass those
-  ;; tests.
-  '("ac_cv_header_mach_mach_types_defs=yes"
-    "ac_cv_header_mach_mach_types_h=yes"
-    "ac_cv_header_mach_machine_ndr_def_h=no"
-    "libc_cv_mach_task_creation_time=yes"))
-
 (define-public glibc
   ;; This is the GNU C Library, used on GNU/Linux and GNU/Hurd.  Prior to
   ;; version 2.28, GNU/Hurd used a different glibc branch.
@@ -927,8 +916,7 @@ the store.")
             ;; On GNU/Hurd we get discarded-qualifiers warnings for
             ;; 'device_write_inband' among other things.  Ignore them.
             ,@(if (target-hurd?)
-                  `("--disable-werror"
-                    ,@%glibc/hurd-configure-flags)
+                  `("--disable-werror")
                   '()))
 
       #:tests? #f                                 ; XXX