summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-11 13:50:30 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:23 +0200
commit77ee97628a2d126a31f60d4ca8fafa70a66be804 (patch)
tree9565b13511fe4bd981d5990903612e8e0e02fe34 /gnu/packages/base.scm
parentf9f2198d82f6aa7147700bed3f9d42a93201d620 (diff)
downloadguix-77ee97628a2d126a31f60d4ca8fafa70a66be804.tar.gz
gnu: binutils: Use gexps.
This is the result of applying ‘guix style -S arguments’ and making
small adjustments.

* gnu/packages/base.scm (binutils)[arguments]: Use gexps.
(binutils-2.33, binutils-gold): Likewise.
* gnu/packages/commencement.scm (binutils-mesboot0, binutils-mesboot1)
(binutils-boot0, binutils-final): Likewise.
* gnu/packages/cross-base.scm (cross-binutils*): Adjust accordingly.
* gnu/packages/embedded.scm (make-propeller-binutils): Use gexps.
* gnu/packages/make-bootstrap.scm (%binutils-static): Use gexps.

Change-Id: I59cbe29760784b09e6d4e80beca9153cb9b495a7
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 30248bf4d1..5e8758f518 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -645,37 +645,37 @@ change.  GNU make offers many powerful extensions over the standard utility.")
       (patches (search-patches "binutils-loongson-workaround.patch"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:out-of-source? #t   ;recommended in the README
-      #:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
-                          ;; on GCC when bootstrapping.
-                          "LDFLAGS=-static-libgcc"
-
-                          ;; Turn on --enable-new-dtags by default to make the
-                          ;; linker set RUNPATH instead of RPATH on binaries.
-                          ;; This is important because RUNPATH can be overriden
-                          ;; using LD_LIBRARY_PATH at runtime.
-                          "--enable-new-dtags"
-
-                          ;; Don't search under /usr/lib & co.
-                          "--with-lib-path=/no-ld-lib-path"
-
-                          ;; Install BFD.  It ends up in a hidden directory,
-                          ;; but it's here.
-                          "--enable-install-libbfd"
-
-                          ;; Make sure 'ar' and 'ranlib' produce archives in a
-                          ;; deterministic fashion.
-                          "--enable-deterministic-archives"
-
-                          "--enable-64-bit-bfd"
-                          "--enable-compressed-debug-sections=all"
-                          "--enable-lto"
-                          "--enable-separate-code"
-                          "--enable-threads")
-
-      ;; For some reason, the build machinery insists on rebuilding .info
-      ;; files, even though they're already provided by the tarball.
-      #:make-flags '("MAKEINFO=true")))
+    (list #:out-of-source? #t ;recommended in the README
+          #:configure-flags #~'(;; Add `-static-libgcc' to not retain a dependency
+                                ;; on GCC when bootstrapping.
+                                "LDFLAGS=-static-libgcc"
+
+                                ;; Turn on --enable-new-dtags by default to make the
+                                ;; linker set RUNPATH instead of RPATH on binaries.
+                                ;; This is important because RUNPATH can be overriden
+                                ;; using LD_LIBRARY_PATH at runtime.
+                                "--enable-new-dtags"
+
+                                ;; Don't search under /usr/lib & co.
+                                "--with-lib-path=/no-ld-lib-path"
+
+                                ;; Install BFD.  It ends up in a hidden directory,
+                                ;; but it's here.
+                                "--enable-install-libbfd"
+
+                                ;; Make sure 'ar' and 'ranlib' produce archives in a
+                                ;; deterministic fashion.
+                                "--enable-deterministic-archives"
+
+                                "--enable-64-bit-bfd"
+                                "--enable-compressed-debug-sections=all"
+                                "--enable-lto"
+                                "--enable-separate-code"
+                                "--enable-threads")
+
+          ;; For some reason, the build machinery insists on rebuilding .info
+          ;; files, even though they're already provided by the tarball.
+          #:make-flags #~'("MAKEINFO=true")))
    (native-inputs (list bison))                   ;needed to build 'gprofng'
    (synopsis "Binary utilities: bfd gas gprof ld")
    (description
@@ -705,7 +705,7 @@ included.")
              (patches '())))
    (arguments
     (substitute-keyword-arguments (package-arguments binutils)
-      ((#:make-flags _ ''()) ''())))
+      ((#:make-flags _ #~'()) #~'())))
    (native-inputs '())
    (properties '())))
 
@@ -715,22 +715,22 @@ included.")
     (arguments
      (substitute-keyword-arguments (package-arguments binutils)
        ((#:configure-flags flags)
-        `(cons* "--enable-gold=default"
-                (delete "LDFLAGS=-static-libgcc" ,flags)))
+        #~(cons* "--enable-gold=default"
+                 (delete "LDFLAGS=-static-libgcc" #$flags)))
        ((#:phases phases '%standard-phases)
-        `(modify-phases ,phases
+        #~(modify-phases #$phases
            (add-after 'patch-source-shebangs 'patch-more-shebangs
              (lambda _
                (substitute* "gold/Makefile.in"
                  (("/bin/sh") (which "sh")))))
            ;; Multiple failing tests on some architectures in the gold testsuite.
-           ,@(if (or (target-arm?)
-                     (target-ppc32?))
-               '((add-after 'unpack 'skip-gold-testsuite
-                   (lambda _
-                     (substitute* "gold/Makefile.in"
-                       ((" testsuite") " ")))))
-               '())))))
+           #$(if (or (target-arm?)
+                      (target-ppc32?))
+                 #~(add-after 'unpack 'skip-gold-testsuite
+                     (lambda _
+                       (substitute* "gold/Makefile.in"
+                         ((" testsuite") " "))))
+                 #t)))))
     (native-inputs (modify-inputs (package-native-inputs binutils)
                      (append bc)))))