summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-30 13:01:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-30 13:01:20 +0200
commitc2e4f14ac8cd3e1ce7f46a192ad0c9acc084b210 (patch)
tree0e57c32acb6d1b3a207f8265510ff13f1335103f /gnu/packages/base.scm
parentdc00f63527bb1b85fe383cd2f21bbd8c4bdbe058 (diff)
downloadguix-c2e4f14ac8cd3e1ce7f46a192ad0c9acc084b210.tar.gz
gnu: glibc/linux: Fix build of glibc-intermediate.
This is a follow-up to commit b2fd8f63679aa4f244c36fdca62f23c00b8eded9.

* gnu/packages/base.scm (glibc/linux)[arguments]: Take patch from either
native-inputs or just inputs; fix syntax error; report errors on patch
failure.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 6dc9e97c34..e896dbe2e1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -670,10 +670,13 @@ store.")
                       ;; TODO: Move the patch to 'patches' in the next update cycle.
                       ,@(if (string-prefix? "i686" (or (%current-target-system)
                                                        (%current-system)))
-                            `(zero? (system* "patch" "-p1" "--force"
-                                             "--input"
-                                             (assoc-ref native-inputs
-                                                        "glibc-memchr-overflow-i686.patch")))
+                            `((unless (zero? (system* "patch" "-p1" "--force"
+                                                      "--input"
+                                                      (or (assoc-ref native-inputs
+                                                                     "glibc-memchr-overflow-i686.patch")
+                                                          (assoc-ref inputs
+                                                                     "glibc-memchr-overflow-i686.patch"))))
+                                (error "patch failed for glibc-memchr-overflow-i686.patch")))
                             '())
 
                       ;; Have `system' use that Bash.