summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-16 15:31:58 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-16 15:43:23 +0100
commitd8f78f54489eae44ffbee3f2af7bbc130e8c0c72 (patch)
tree8afe3d76436cc236a64b8cb0be71de80039ed689 /gnu/packages/base.scm
parent40a461fd97fb865987e4f6cc41fee6ee6408851d (diff)
downloadguix-d8f78f54489eae44ffbee3f2af7bbc130e8c0c72.tar.gz
gnu: ld-wrapper: Use _IOLBF on Guile 2.0 only.
* gnu/packages/base.scm (make-ld-wrapper)[arguments]: Wrap use of
'_IOLBF' in 'cond-expand' and use 'line instead on Guile > 2.0.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d74d304de1..196106fa29 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -546,7 +546,9 @@ wrapper for the cross-linker for that target, called 'TARGET-ld'."
                                       '(string-append bin "/ld")))
                             (go  (string-append ld ".go")))
 
-                       (setvbuf (current-output-port) _IOLBF)
+                       (setvbuf (current-output-port)
+                                (cond-expand (guile-2.0 _IOLBF)
+                                             (else 'line)))
                        (format #t "building ~s/bin/ld wrapper in ~s~%"
                                (assoc-ref %build-inputs "binutils")
                                out)