summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-28 12:04:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:21 +0300
commitf9b8f38908da660a2f775de2656e47f3e9ec75bc (patch)
treeb2cb42b00570fc35def90d712beb9012122f8bbd /gnu/packages/base.scm
parentf3114ac4f0f1ac20a85dcb20c44cb32e06c22a14 (diff)
downloadguix-f9b8f38908da660a2f775de2656e47f3e9ec75bc.tar.gz
gnu: glibc-2.33: Fix building for riscv64-linux.
* gnu/packages/base.scm (glibc-2.33)[source]: Add patch.
* gnu/packages/patches/glibc-2.33-riscv64-miscompilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2f276c447..39c7e5ef5f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1066,12 +1066,13 @@ with the Linux kernel.")
                (base32
                 "1zvp0qdfbdyqrzydz18d9zg3n5ygy8ps7cmny1bvsp8h1q05c99f"))
               (patches
-               ;; Remove a patch that's become irrelevant and that does not
-               ;; apply to this version.
-               (remove (lambda (patch)
-                         (string=? (basename patch)
-                                   "glibc-hurd-clock_gettime_monotonic.patch"))
-                       (origin-patches (package-source glibc))))))
+               (cons (search-patch "glibc-2.33-riscv64-miscompilation.patch")
+                     ;; Remove a patch that's become irrelevant and that does not
+                     ;; apply to this version.
+                     (remove (lambda (patch)
+                               (string=? (basename patch)
+                                         "glibc-hurd-clock_gettime_monotonic.patch"))
+                             (origin-patches (package-source glibc)))))))
     (arguments
      (substitute-keyword-arguments (package-arguments glibc)
        ((#:configure-flags flags ''())
@@ -1379,6 +1380,9 @@ test environments.")
    (make-glibc-utf8-locales glibc)))
 
 ;; Packages provided to ease use of binaries linked against the previous libc.
+(define-public glibc-locales-2.33
+  (package (inherit (make-glibc-locales glibc-2.33))
+           (name "glibc-locales-2.33")))
 (define-public glibc-locales-2.32
   (package (inherit (make-glibc-locales glibc-2.32))
            (name "glibc-locales-2.32")))