summary refs log tree commit diff
path: root/gnu/packages/bdb.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-23 22:47:39 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-23 23:33:09 +0100
commit12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729 (patch)
tree2c85197829465c6d48075166bd313d6c228508ef /gnu/packages/bdb.scm
parentbbb7a00e9a224d812a56c67956efb3e8a840cf0a (diff)
downloadguix-12abb19dfbd90089e04ccbc94f0bd8ee2cbe3729.tar.gz
gnu: Remove unnecessary closures around `arguments' value.
* gnu/packages/algebra.scm (pari-gp): Remove closure around the value of
  `arguments'.
* gnu/packages/bdb.scm (bdb): Likewise.
* gnu/packages/mit-krb5.scm (mit-krb5): Likewise.
* gnu/packages/openssl.scm (openssl): Likewise.
* gnu/packages/perl.scm (perl): Likewise.
Diffstat (limited to 'gnu/packages/bdb.scm')
-rw-r--r--gnu/packages/bdb.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index c9cdf4af6b..9a626b17d7 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -35,19 +35,18 @@
                      "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
    (build-system gnu-build-system)
    (arguments
-    (lambda (system)
-      `(#:tests? #f ; no check target available
-        #:phases
-        (alist-replace
-         'configure
-         (lambda* (#:key outputs #:allow-other-keys)
-           (let ((out (assoc-ref outputs "out")))
-             (zero?
-              (system* "./dist/configure"
-                       (string-append "--prefix=" out)
-                       (string-append "CONFIG_SHELL=" (which "bash"))
-                       (string-append "SHELL=" (which "bash"))))))
-         %standard-phases))))
+    '(#:tests? #f                            ; no check target available
+      #:phases
+      (alist-replace
+       'configure
+       (lambda* (#:key outputs #:allow-other-keys)
+         (let ((out (assoc-ref outputs "out")))
+           (zero?
+            (system* "./dist/configure"
+                     (string-append "--prefix=" out)
+                     (string-append "CONFIG_SHELL=" (which "bash"))
+                     (string-append "SHELL=" (which "bash"))))))
+       %standard-phases)))
    (synopsis "db, the Berkeley database")
    (description
     "Berkeley DB is an embeddable database allowing developers the choice of