summary refs log tree commit diff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-28 18:14:49 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-28 18:14:49 +0100
commit62b76320b40641fef3a23eca1e0916098ce09bde (patch)
tree36ad1349f21f146c0f0bb81a16aa79cc5b39db9a /gnu/packages/bdw-gc.scm
parenta74da6b015f0c10534dd90186d841a720d5db7cd (diff)
downloadguix-62b76320b40641fef3a23eca1e0916098ce09bde.tar.gz
gnu: libgc: Change URLs to point to hboehm.info.
* gnu/packages/bdw-gc.scm (libgc)[source, home-page, license]: Update
  URL.
  (libatomic-ops)[source, home-page]: Likewise.
  (libgc-7.4)[source]: Likewise.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index b223721520..1955cd3ee1 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -29,9 +29,8 @@
    (version "7.2d")
    (source (origin
             (method url-fetch)
-            (uri (string-append
-                  "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
-                  version ".tar.gz"))
+            (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
+                                version ".tar.gz"))
             (sha256
              (base32
               "0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))
@@ -58,10 +57,9 @@ simple collector interface.
 
 Alternatively, the garbage collector may be used as a leak detector for
 C or C++ programs, though that is not its primary goal.")
-   (home-page "http://www.hpl.hp.com/personal/Hans_Boehm/gc/")
+   (home-page "http://www.hboehm.info/gc/")
 
-   (license
-    (x11-style "http://www.hpl.hp.com/personal/Hans_Boehm/gc/license.txt"))))
+   (license (x11-style (string-append home-page "license.txt")))))
 
 (define-public libatomic-ops
   (package
@@ -70,7 +68,7 @@ C or C++ programs, though that is not its primary goal.")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/libatomic_ops-"
+                    "http://www.hboehm.info/gc/gc_source/libatomic_ops-"
                     version ".tar.gz"))
               (sha256
                (base32
@@ -83,7 +81,7 @@ C or C++ programs, though that is not its primary goal.")
 memory update operations on a number architectures.  These might allow you to
 write code that does more interesting things in signal handlers, write
 lock-free code, experiment with thread programming paradigms, etc.")
-    (home-page "http://www.hpl.hp.com/research/linux/atomic_ops/")
+    (home-page "https://github.com/ivmai/libatomic_ops/")
 
     ;; Some source files are X11-style, others are GPLv2+.
     (license gpl2+)))
@@ -93,9 +91,8 @@ lock-free code, experiment with thread programming paradigms, etc.")
     (version "7.4.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
-                    version ".tar.gz"))
+              (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
+                                  version ".tar.gz"))
               (sha256
                (base32
                 "10z2nph62ilab063wygg2lv0jxlsbcf2az9w1lx01jzqj5lzry31"))))