summary refs log tree commit diff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-20 23:45:41 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-20 23:45:41 +0200
commitfba96c4885aa5b95c42120387db0450d9794508a (patch)
treec1f957716f27c585c75d3060e8090ac8d4cd4d15 /gnu/packages/bdw-gc.scm
parentcfbf7877a673400881db20521a9d6a44261ed62b (diff)
downloadguix-fba96c4885aa5b95c42120387db0450d9794508a.tar.gz
gnu: libgc: Switch to 7.2d.
* gnu/packages/bdw-gc.scm (libgc): Upgrade to 7.2d.
  (libgc-7.2): Remove.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index e119fc0bb9..ad0577b1ea 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -25,7 +25,7 @@
 (define-public libgc
   (package
    (name "libgc")
-   (version "7.2alpha6")
+   (version "7.2d")
    (source (origin
             (method url-fetch)
             (uri (string-append
@@ -33,7 +33,7 @@
                   version ".tar.gz"))
             (sha256
              (base32
-              "05jwadjbrv8pr7z9cb4miskicxqpxm0pca4h2rg5cgbpajr2bx7b"))))
+              "0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))
    (build-system gnu-build-system)
    ;; TODO: Build with -DUSE_LIBC_PRIVATES (see make-bootstrap.scm).
    (synopsis "The Boehm-Demers-Weiser conservative garbage collector
@@ -58,17 +58,3 @@ C or C++ programs, though that is not its primary goal.")
    ;; permissive X11-style license:
    ;; http://www.hpl.hp.com/personal/Hans_Boehm/gc/license.txt
    (license x11)))
-
-(define-public libgc-7.2
-  ;; This is the latest final release of the 7.2 series.
-  ;; TODO: Use it as the default when doing a core-updates.
-  (package (inherit libgc)
-    (version "7.2d")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
-                   version ".tar.gz"))
-             (sha256
-              (base32
-               "0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))))