summary refs log tree commit diff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/benchmark.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm36
1 files changed, 32 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 577196e3df..d9796d2999 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -41,6 +41,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
+  #:use-module (gnu packages opencl)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-science)
@@ -220,7 +221,7 @@ This can give a much better understanding of the command's performance.")
 (define-public benchmark
   (package
     (name "benchmark")
-    (version "1.5.5")
+    (version "1.5.6")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -229,7 +230,7 @@ This can give a much better understanding of the command's performance.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ijv4idcjsyy61dab59ywbx0xdbws44kxgqjr1ylaxzwknh745qf"))))
+                "030g4d8vpn2442dsap0qw86lsw7xfl36k0x0x9bn0vvm11qvjn8c"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("googletest-source" ,(package-source googletest))
@@ -240,8 +241,7 @@ This can give a much better understanding of the command's performance.")
          (add-after 'unpack 'unpack-googletest
            (lambda* (#:key inputs #:allow-other-keys)
              (copy-recursively (assoc-ref inputs "googletest-source")
-                               "googletest")
-             #t)))))
+                               "googletest"))))))
     (home-page "https://github.com/google/benchmark")
     (synopsis "Microbenchmark support library")
     (description
@@ -384,3 +384,31 @@ It is designed to measure the effect of changes in Linux kernel design or
 system configuration changes such as CPU, I/O scheduler and filesystem changes
 and options.  With careful benchmarking, different hardware can be compared.")
     (license license:gpl2+)))
+
+(define-public clpeak
+  ;; Release 1.1.0 is too old for our opencl-clhpp. This commit supports
+  ;; cl2.hpp.
+  (let ((commit "6d59cb64997a53c35207b77a63d2e9f0e84de5fd"))
+    (package
+      (name "clpeak")
+      (version (git-version "1.1.0" "0" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/krrishnarraj/clpeak.git")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "0qmhdjyhwl7gfgyqxsddqn6zpp3b57503m16h7jv6illy3lfvji1"))))
+      (build-system cmake-build-system)
+      (home-page "https://github.com/krrishnarraj/clpeak")
+      (inputs
+        `(("opencl-clhpp" ,opencl-clhpp)
+          ("opencl-icd-loader" ,opencl-icd-loader)))
+      (synopsis "OpenCL benchmark tool")
+      (description
+        "A synthetic benchmarking tool to measure peak capabilities of OpenCL
+        devices.  It only measures the peak metrics that can be achieved using
+        vector operations and does not represent a real-world use case.")
+        (license license:unlicense))))