summary refs log tree commit diff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-11-03 16:34:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-03 22:49:11 +0100
commit6ea450f3903ae383ccd556d3ae8da47cc19c820c (patch)
tree59d4eba96cd320557a3c31132390fac01299c11f /gnu/packages/bioconductor.scm
parentbcf0ecd1ecf2f1aa47c606a784bc4b411d3798ff (diff)
downloadguix-6ea450f3903ae383ccd556d3ae8da47cc19c820c.tar.gz
gnu: r-debcam: Update to 1.20.0.
* gnu/packages/bioconductor.scm (r-debcam): Update to 1.20.0.
[arguments]: Remove old comment and enable tests.
[inputs]: Replace icedtea with openjdk11.

Change-Id: Id8afa7e53d69fa7767901249cab58fe5555d0e48
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 74dd7febfe..f85cf005e5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4723,13 +4723,13 @@ set analyses, and can deal with repeated or longitudinal data.")
 (define-public r-debcam
   (package
     (name "r-debcam")
-    (version "1.18.0")
+    (version "1.20.0")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "debCAM" version))
               (sha256
                (base32
-                "11vqfkyd3fklc8fhn850kklph8x4pmwclb9xbqji4i21222m89hh"))
+                "1swqqrlwin2i2qq46qyfziblbfsfyd5hf6w39hygp7fdkpic14b7"))
               (snippet
                '(for-each delete-file
                           '("inst/java/CornerDetect.jar"
@@ -4738,9 +4738,6 @@ set analyses, and can deal with repeated or longitudinal data.")
     (build-system r-build-system)
     (arguments
      (list
-      ;; XXX: since the upgrade to R 4.3.0 this package takes too long to be
-      ;; loaded.
-      #:tests? #false
       #:configure-flags '(list "--fake")
       #:modules
       '((guix build r-build-system)
@@ -4768,7 +4765,7 @@ set analyses, and can deal with repeated or longitudinal data.")
          (add-after 'install 'strip-jar-timestamps
            (assoc-ref ant:%standard-phases 'strip-jar-timestamps)))))
     (inputs
-     (list (list icedtea "jdk")
+     (list (list openjdk11 "jdk")
            java-pj))
     (propagated-inputs
      (list r-apcluster