summary refs log tree commit diff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:25:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:34:44 +0200
commitf78ff75b411fe2d07b18529db6fb1da231bcc4cd (patch)
treee8791c54f657704ca75ee9387975ad62e491c06a /gnu/packages/bioconductor.scm
parenta88230a1bc332ee41eb1e0080f020e0178f78d5a (diff)
downloadguix-f78ff75b411fe2d07b18529db6fb1da231bcc4cd.tar.gz
gnu: r-genomicfeatures: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-genomicfeatures): Move from here...
* gnu/packages/bioconductor.scm (r-genomicfeatures): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2b3c232d53..7278bb486b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2313,6 +2313,49 @@ junction detection, and working with the nucleotide content of the
 alignments.")
     (license license:artistic2.0)))
 
+(define-public r-genomicfeatures
+  (package
+    (name "r-genomicfeatures")
+    (version "1.42.3")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "GenomicFeatures" version))
+              (sha256
+               (base32
+                "168cf261vmcqffbzassavkjyz9a2af0l6zbv9cagkx6b1qrk3siz"))))
+    (properties
+     `((upstream-name . "GenomicFeatures")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-biomart" ,r-biomart)
+       ("r-biostrings" ,r-biostrings)
+       ("r-dbi" ,r-dbi)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-iranges" ,r-iranges)
+       ("r-rcurl" ,r-rcurl)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-rtracklayer" ,r-rtracklayer)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-xvector" ,r-xvector)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/GenomicFeatures")
+    (synopsis "Tools for working with transcript centric annotations")
+    (description
+     "This package provides a set of tools and methods for making and
+manipulating transcript centric annotations.  With these tools the user can
+easily download the genomic locations of the transcripts, exons and cds of a
+given organism, from either the UCSC Genome Browser or a BioMart
+database (more sources will be supported in the future).  This information is
+then stored in a local database that keeps track of the relationship between
+transcripts, exons, cds and genes.  Flexible methods are provided for
+extracting the desired features in a convenient format.")
+    (license license:artistic2.0)))
+
 (define-public r-genomicranges
   (package
     (name "r-genomicranges")